[Known Issue][PS4/XB1] "Call Me Ahab" Trophy not unlocking for players

Update 08/22
In going through the different reports surrounding achievements, the team believe they may have found a cause behind the issue with Call Me Ahab not unlocking. While the issues with the crafting menu is also being investigated, players may have success unlocking this achievement if the trophies are crafted on game-generated islands. If you try this please let me know if it was successful for you.

Issue Summary:
When a player defeats all 3 bosses and crafts the trophies for those bosses, if all 3 trophies are in the player’s backpack at any stage, “Call Me Ahab” will be unlocked.
For this issue, “Call Me Ahab” fails to unlock when these conditions are met.

Workarounds:
Crafting each of the 3 trophies on the starting island has worked as a workaround for some players.
Unfortunately for players who have already crafted the trophies, there is currently no known workaround for prompting the trophy to unlock.

ArmchairTuna66 noted that they crafted their trophies through the quick craft menu and were able to unlock the trophy without being on the starting island.

It may be worth trying:

  • Clearing the cache of your console*, reloading the save and placing the trophies in your backpack
  • Travelling to your starting island, saving and repeating the steps above
  • Saving and keeping a backup save before traveling to the plane carrier and completing the endgame scenario to see if it unlocks at this point.
  • Crafting via the regular crafting menu instead of the quick crafting menu, and doing it one at a time (opening and closing the menu) rather than one after another.

*To clear the the cache of your console, shut down and unplug the console for 2-5 minutes. Then plug back in and reboot.

Further reporting:
Please let me know what crafting methods you have tried and also if the colour splash behind the items in the crafting menu changes colour / registers that the trophies have been crafted.

Updated main post with potential new workaround and further reporting details.

Having this problem on a PS5 running the PS4 game, version 2083, single player. Have every other trophy in the game, these have the “crafted” splash behind their image in the crafting menu.

The Eel and Squid were crafted on the starting island, unfortunately I crafted the Shark at sea and don’t have a backup save before doing so. They were crafted using the regular crafting menu.

Clearing console cache did not work. Putting them in my bag after reloading a save before the end game did not work.

Hi SnowArcaten, welcome to the forums.

I’m sorry to hear this issue is affecting your save also. Thank you for sharing the details or your experience - I shall add this to my report for the team.

After the update to 2083, players have reported their story items have locked again in their crafting menu. Have you noticed this happening in your save at all or is the crafting menu unchanged? I don’t believe these issues are related, but I wanted to double check just in case.

2 posts were merged into an existing topic: [Known Issue][PS4/XB1] Crafting Menu Reset / Story Items Locked

Hi Clare,

I also seem to be having the same issue.

PS5 Console on v2083 (Solo).

I crafted all 3 items on my starting island, all have orange backgrounds but trophy does not pop.

I have also tried the save/reload and add to backpack and also clearing the PS5 cache and no luck. Took me quite some time to get to this point with work and can’t restart, is there a known workaround for this or can I get a trophy pop? If needed I have recording of the trophies on console with reloading.

J’ai le même problème avec le trophée je m appelle achab aider moi s il vous plaît

Translation added by Clare using Google Translate
I have the same problem with the trophy my name is achab help me please

Hi Houta2020,

I have added an English translation to your post. We ask that players post in English or include a translation in their posts as per the Rules and Guidelines of the forums:

As our Staff and Moderators are all English Speakers, please avoid using other languages. We need to be able to read everything posted in order to effectively run the forums. If you are unable to or do not feel confident writing in English, please use an online translator. If you are concerned about your post being mistranslated you may post in your preferred language on the condition that a 1:1 translation accompanies it.

Thank you for your understanding.

With regards to your issue with “Call Me Ahab’’ the current known workarounds are detailed in the post above. The team are still working on this issue as well as its potential tie to other issues with crafting items remaining locked. If you are having issues crafting the trophies themselves, please see the following post: [Known Issue][PS4/XB1] Crafting Menu Reset / Story Items Locked

If your experience is slightly different or you wish to discuss it further, please create a new Console Bug Report with as much information as possible and I will address it directly as soon as possible.

Thank you.

Update 08/22 - Added to original post above ^

In going through the different reports surrounding achievements, the team believe they may have found a cause behind the issue with Call Me Ahab not unlocking. While the issues with the crafting menu is also being investigated, players may have success unlocking this achievement if the trophies are crafted on game-generated islands. If you try this please let me know if it was successful for you.