[2083] Trophies not unlocking

Same thing here megalodon trophy did not get markes as crafter making my save file unable to get the the “call me ahab” trophy and also “gotta craft them all” trophy and the platinum of the game i am on day 50 i do not want to make a third new game and start everything all over again, so will stop playing the game until this get fixed

Now i deleted the game and save file and redownloaded sim both and now the megalodon trophy is marked as crafted but still no trophy any way to make it pop now??

Hi @MarcioBarazzetti, welcome to the forums,

I had originally moved your post to a known issues post that I believe is most relevant to the issue you described but decided it would be best to create a new topic so I could address this with you directly and understand which issues are affecting you. The link to each potentially relevant post should be at the bottom of your first post above.

The team are aware of and are investigating and issue regarding the bosses and the story items remaining locked. However if I misunderstood and you are able to craft the end game items but the achievements are not unlocking, please let me know.

As described in the workarounds in the topic [Known Issue][PS4/XB1] Crafting Menu Reset / Story Items Locked, players have been able to craft the boss trophies and story items by accessing the Quick Craft menu to craft the items. This however may need to be done in the boss area after defeating them. It is unknown at the moment what impact this is having on the unlocking of the game trophies (some players have received the one for their first boss) because of the issue with the crafting menu.

My apologies if I have misunderstood your issue (and for moving your post a number of times), any extra details you can provide about your experience and which areas of the game are affected for you will help me to pass the relevant information onto the team.

The only problem is the 3 bosses trophy not popping now i did turn off the console redownloaded the game and the 3 bosses heads is shown as craft but no trophy still one good idea that would fix for everyone having this issue is change the trigger for the pop insted pop for craft the 3 bosses heads change for hang the 3 bosses heads in a wall this certainly will be easier

Thank you for those details MarcioBarazzetti, it is my understanding from speaking to the team that the original trigger for this trophy required the 3 trophies to be in the player’s backpack. However the team are aware that players are experiencing issues unlocking this trophy and are investigating it.

Other players have reported successfully unlocking if all 3 trophies were crafted on the starting island, or if they were all crafted via the quick-craft menu. However I understand these workarounds are not ideal and they have not worked for every player who tried them. I will pass your details as well as your feedback regarding the trigger onto the team.

And i want to report that i entered several other persons worlds they droped for me the bosses heads and still did not poped another workaround for you to sugest to the team is made the bosses head trophy destructible so after you destroy them you can craft them back and maybe get the trophy

Hi MarcioBarazzetti,

Thank you for letting me know about your experience in multiplayer games where you joined the game. Do you know if the trophies had popped for the hosts at the same time or if they were experiencing the same issue?

Thank you also for your additional suggestion on crafting and recrafting the head trophies, I shall pass this onto the team too.

For them it poped but if the dropped the heads to me and in picked them up did not pop for me also i did go the crafting menu to try craft the heads in their world the heads ate shown as the bosses did not have been killed yet

Thank you for letting me know those details MarcioBarazzetti.

You’ve probably already done this, but just to be sure, did you check your achievement list for the game on your console? Players in the past have mentioned not getting a notification in game for achievements even if they unlock, so it’s good to double check that list too.

Yes i did, well i am looking foward for the next update you do know if is coming out this next month?
When it does i will reply here to let other players know if its fixed

1 Like

Hi MarcioBarazzetti, my apologies for my delay in responding to your message. Thank you for confirming you checked the external achievements list also.

While the team are working on the next update I do not have details on when it will be released or confirmation if a fix for this issue will be included. Any announcements about updates will be posted in the News and Announcements section so please keep an eye out there.

A post was split to a new topic: Trophy unlocking issues

A post was split to a new topic: [2104] Trophies still not unlocking

2 posts were split to a new topic: [2104] Cannot craft boss trophies (moved post)

Even after the update the ‘gotta craft them all’ trophy isnt unlocking even though i crafted everything there is

1 Like

Hi Loeckiey, my apologies for the confusion as I believe the user above (post now moved) was refering to the boss trophies in the "Story"section of the crafting menu being unlocked.

However the team are continuing to work on achievements issues that are resulting from issues with crafting menu resets or adjustments. Including the “Call Me Ahab” trophy and “Gotta Craft Them All”.

Hi. Gotta craft them all not unlocking as mentioned already, I’ve noticed the my crafting belts pouch 2 was not brown in the background. Even after crafting the Megalodon trophy the background isn’t brown. I think the team needs to take a look at the crafting monitor because I think it’s not working properly. I’ve restarted a few times and crafted a belt and the background is still grey. Please :pray: help it’s the last trophy I need

For me everything has a brown background and its still not even unlocking🙄

1 Like

Thank you @Kingzcrown18 and @Loeckiey for those details. I will pass them onto the team.

For anyone else who finds this thread, please refer to the follow thread going forward and post any comments / info there, thank you.

1 Like

Thanks. I ran a test last night and the 3 crafting sections that don’t work are. Boss trophies, plane parts, and tool belt hope it helps. Thanks again

1 Like