[PS4] [Trophies] “Call me Ahab” trophy not unlocking

I have defeated all three bosses, and have crafted each boss trophy. However, I have not gotten the PlayStation “Call me Ahab” trophy for collecting all 3 boss trophies.
I did, however, get a PlayStation trophy for collecting the first boss trophy

MULTIPLAYER - No setting changes apart from Passive Wildlife

Defeat the bosses and craft trophies using the Quick Craft feature.

May have been due to my friend getting the final hit on 2/3 of the bosses.

Hi ThatR3XZ,

Welcome to the forums and thank you for reporting this issue.

There is an issue the team are investigating regarding this trophy, I have a known issue report on it here: [Known Issue][PS4/XB1] "Call Me Ahab" Trophy not unlocking for players

While workarounds that have worked for players involve either crafting them on the starting island, or crafting them using the quick craft feature, your comment relating to your friend getting the final hit on the bosses is an interesting one. I shall pass this info onto the team.

Please let me know:

  • For the first boss trophy that is unlocked for you, is this the same boss you got the final hit for?

  • Where were you when you crafted each trophy?

  • Have you tried placing each of the trophies in your backpack together at all?

  • Can you confirm if your friend was Player 2 or the host in this game? Please also let me know if the same friend was present for the boss where you landed the final hit.

I understand trophies not unlocking can be frustrating and any extra information you can provide about your experience would be greatly appreciated. Thank you.

2 posts were merged into an existing topic: [Known Issue][PS4/XB1] “Call Me Ahab” Trophy not unlocking for players