Bugged trophy Call me Ahab

I played the game in multiplayer mode and didn’t get the trophy for collecting all the sea monster trophies.

I’ve already made them on the main island, I’ve already hung them and tried to take them to other islands.

Please, I would like to know how to solve this… only this trophy is missing for me and my cousin to get all trophies in the game.

Hi Jardim, welcome to the forums,

This is an issue the team are aware and are investigating. I’m sorry to hear it has affected your save.

When you say you made them on your “Main Island” are you refering to the island you use as a base or your starting island? I have been informed by the team that placing the trophies in your backpack can work as a trigger for the trophy. Please try this if you have not done so already.

Please also let me know if you are the Host or Player 2 for this multiplayer save? Are you playing with your cousin or have they experienced the same issue in their own save?

Hi Clare
I was referring to my starting island.
I’ve already tried putting the trophies in my backpack and it didn’t work.
I am the host for this multiplayer save.
I have this save along with my cousin, we played since the beginning of the game.
All other trophies were obtained for me and him, only this one is giving a bug :slightly_frowning_face:
any other ideas tell me i’ll try it on my save

Hi Jardim,

Thank you for letting me know. I’m sorry to hear the workaround of crafting them on the first starting island did not work for you and neither did placing them in your backpack, I’ll alert the team to the difference between your experience and that of other players. I unfortunately don’t know of any other workarounds that have worked for players.

It’s a long shot, but it may be worth trying the following:

  • Placing the trophies on the first island, saving and exiting the game.
  • Clear the cache of the console by shutting down and unplugging your system for 2 minutes.
  • After rebooting the console, load into the save and try to place the trophies in your backpack while on the starting island. Have your cousin try the same.

Some players have mentioned prompts for trophies not showing, so it may also be worth double checking your trophy list on your console after trying this too.

I know there are a few posts on this topic, and I think all of them have to do with not being able to earn “Call me Ahab” on the Playstation consoles. I just wanted to throw my 2 cents in, even though I am playing on the Xbox Series X, in the hopes that it may provide additional details even though it is a success story. I can’t say for certain when I unlocked it, I thought it was immediately after I killed the final boss (for me the last one was the Megalodon) or after I crafted the trophy upon returning to my home island. My home island is not the starter island, it is a cliff island directly SE of the starter island (down one island from the center if looking in the cartographer). The order I defeated the bosses and crafted the respective trophies in was: Squid, Eel, Shark. In each case, I travelled immediately back to my home island and crafted the newly unlocked item and dropped it on the floor in my house. I am fairly certain the achievement unlocked for me without having all 3 in my inventory at once, and definitely without crafting any of them on the starter island. I did, however, pick them all up at once a few game days later to hang them on hooks on the outside of my house. I don’t remember seeing it pop up at that point, so I think it had already happened after crafting the last one. Maybe not much help, but that’s my experience.

Happy trophy hunting, fellow survivors!

Sorry for such the long post above, I always seem to get wrapped up and write a novel about everything. Basically, just pointing out that it seems to me the issue may be isolated to the Playstation consoles (unless someone knows otherwise). Also I don’t think I met either of the mentioned conditions (crafting on starter island and/or having all 3 in the inventory at once) and was still able to get it.

That’s great info to have, thank you for sharing ArmchairTuna66. I’ll add this comments to my report for the team and I appreciate you sharing your experience in detail. The more information we have on steps players took the easier it can be to test or replicate issues for the team so please don’t worry about long posts!

Hello everybody !
Like a lot of people lately I am also encountering the bug, how can I find my island of origin?
Does it work even if the trophies have already been crafted?
Is the development team working on a fix?
Thanks in advance for answers!

My origin island always seems to be in the exact center of my cartographer, though this may not always be the case as I have not tried a wide variety of seed numbers. Maybe the easiest way to be sure would be to enter the cartographer on that save file (from the main menu) then look at the seed number at the bottom and write it down. Switch to another save slot (if you have any open ones that you are not using) and enter the cartographer and select random world and enter the appropriate seed number, and start a new game. Build a shelter on your origin island in that game (with the same seed number as your original main save) then save and exit back to the main menu to check your cartographer to see where you are. Then use that information when you switch back to your main save slot as it should always be the same. Another helpful clue, in my experience only the small crabs will spawn on the origin island. There shouldn’t be any giant crabs or other land animals besides the small crabs, and also as far as I know every origin island is one of the smaller types with no cliffs on it.

Hope this helps!

Hi @Vilink welcome to the forums,

As @ArmchairTuna66 mentioned, the starting island is in the centre of the map. This is always the case for saves. If you’re playing multiplayer it may be tricky to navigate back there, depending on how far you traveled. But if you are playing a single player save, if you open the cartographer the island highlighted with the red square is the one you’re on, once the island in the centre is highlighted in red you’ll know you’re back on your first island. (Multiplayer does not affect the cartographer in the same way, this will always highlight the middle island even if you’re not there)

No workarounds have been successful so far if the trophies are already crafted, unfortunately. The team are aware of this issue and will be working to resolve it however I do not know how long that will take / when a fix will be released.

I have a Known Issues post on this here: [Known Issue][PS4/XB1] "Call Me Ahab" Trophy not unlocking for players and if anything changes I’ll update that post.

Thank you for the answer !
Do you know if this works even though I have already made one of the two trophies? (if I come back to my first island)

I cannot say for certain, but as the trophy usually triggers when the 3rd trophy is made, this may work for you if you travel back to your first island and craft the remaining two trophies there. I would recommend saving before hand in case you want reload the save try any other workarounds.

Please let me know if this works for you though! This would be good information to have for other players and for the team members investigating.

No problems ! I try this today ! thx !

So I tested what was written but without success.
I can nevertheless bring the following elements:

I was on my home island, only one trophy (the big fish) was in my inventory, I then made the squid trophy then the shark (via the shortcut menu then the classic menu)
I have noticed several times that the trophies were not considered as “made” (they remained on a gray background instead of a brown background)

I will continue to do tests
I remain attentive to your proposals!

PS : Another information from a Playstation forum :
I had the same glitch yesterday. Crafted the first and the trophy popped normal, but after crafting the third one, Call Me Ahab didn’t. Fortunatelly I saved the game before crafting the monster trophies so I loaded the save and tried again, this time the trophy unlocked with no issues.

Some notes about the problem:

  • It looks like it isnt tied to a specific sea monster.(M0biUs_0_o - PSNProfiles) reported having the issue with the Eel, but it was the first one I crafted and Hunter of the High Seas popped immediately.

  • When the glitch happened to me, I crafted the sea monster trophies from the quick craft wheel. The second time, I tried using the normal crafting menu going to the specific session and crafting the trophies one by one from there and it worked."

Im on the same situation, I have build “Eel” on first

I’m sorry to hear the trophy did not unlock for you Vilink. The fact that they also did not appear as crafted in the crafting menu is also interesting. It’s possible the crafting is not registering correctly for some reason. I’ll alter the team to this and the potential difference between crafting via the quick menu and the main menu - there may be something here too.

If you try crafting both via the classic menu and the trophy still does not unlock, please let me know. Rereading your post it seems that this may be what you mean you tried, but I want to make sure.

Thank you for taking the time to share this update on what you tried and sharing other reports you’ve found outside our official forums.

Hello, thank you for your feedback, I have performed the following actions (I still have the trophy)

craft both via the quick menu
make both via the classic menu
make one via the classic menu then sleep and make the second via the classic menu
same thing in quick menu
post the trophies on the ground then craft them again
(I was still on the starting island)
feel free to ask me if you need any information (I paused the game for this reason)

Thank you for responding so quickly Vilink, I will add this information to my report for the team. If they have any further questions or suggestions, I’ll reach out here via this thread :slight_smile:

Thank you again!

Also wanted to add, though I play on Xbox Series X multiplayer so it may not be relevant, I crafted all 3 of mine through the quick craft menu at separate times. Along with all the other details I stated in posts above, and was successful in getting achievement on the first try. Just noticed this additional info and wanted to add my details as well.

Hey guys, Jardim again
I tried all the ideas given here on the forum.
@Clare Unfortunately I haven’t got the trophy yet.
So I really ask the team to look for a solution.
There’s no way around this bug, I’ve tried EVERYTHING (create on my main island, create on all islands in my save, die with trophies in inventory, finish the game with trophies in inventory and so on…
Nothing worked :cry:
I’m waiting for an update to fix this trophy.
I don’t see another way to get it right now.
Thanks to everyone who tried to help!
Merry Christmas to everyone :santa:

Sorry for the delay in responding to this thread over the holidays.

@ArmchairTuna66 - Thank you for letting me know which crafting mention you used. I shall note this for the team :+1:

@jardim - I’m sorry to hear the suggestions from myself and others on the forums have not helped to unlock this trophy for you. I am continuing to share information with them about what has and has not worked for players and I will add a note that the none of the suggestions have worked for you and share your feedback too. Unfortunately I do not yet have an update on when a fix may be released, but if the team send any updates my way I will let the community know. Thank you for your patience and understanding, I know this is a frustrating and disappointing issue.
A belated Merry Christmas to you too :slight_smile: