Bugged trophy Call me Ahab


Somebody have any news about this trophy ?

Hi @Vilink - from the devs side, the fix for this is still a work in progress, I do not have any updates from the team on how far along they are. If I recieve any updates they’ll be posted here: [Known Issue][PS4/XB1] "Call Me Ahab" Trophy not unlocking for players


I’m having the same issue, on xbox and finally got the last monster (squid) and it hasn’t unlocked, I’ve tried the workarounds and just kept them in my backpack and still doesn’t unlock.

Thanks :slightly_smiling_face:

Hi sykoste, welcome to the forums,

I’m sorry to hear this issue has affected your save also. Thank you for reporting it and letting me know what console you’re on. Please also let me know if you crafted the trophies on your starting island or in different locations and at different times.

Thank you again.

Hi Clare, different islands and at different times, as they where beaten. I’ve loaded the save on a One X & Series X and hasn’t unlocked.


Thank you for letting me know sykoste, I’ll note this as what occured in your save for the team as well as what you tried to prompt it to unlock.

At the moment he only workaround that has worked for multiple players involves creating the trophies all on the starting island. However I understand this is not ideal for players and not possible for those who’ve already crafted trophies elsewhere.

ArmchairTuna66, who also plays on Xbox, mentioned above that they crafted theirs through the quickcraft menu and were able to unlock them, however I haven’t heard if this has been successful for other players.

If you still have a save from before crafting your most recent trophy, it worth trying to craft it through the quickcraft menu instead of the regular one to see if that makes a difference for you - please let me know if it does.

If the team have any updates or any other workarounds are found they will be posted in [Known Issue][PS4/XB1] "Call Me Ahab" Trophy not unlocking for players