[2104] Crafting Story items and Trophies

Hi again! So i’m coming to give a little bit more informations about our current situation but i cannot craft the sea monsters trophies (me and my mate killed the 3 of them) i even went to the big boat where is the plane to actualize (?) my objective but nothing and i really don’t want to do it all over again i gotta say…

Hi Dokrayn,

Thank you for providing additional infomation about your situation. To be sure I understand everything you’re experiencing, I wanted to ask you some questions.

  • You mentioned you are unable to craft the sea monster trophies in your game. Please confirm for me that you are refering to the trophy mounted monster parts that you would hang on a wall in game. If so, are you attempting to craft them when holding them up to the wall? There is an issue with hooks and shelves that may be affecting this. Please try crafting them on the ground to see if that helps at all.

  • If the above does not reflect your situation, please describe for me what you are seeing when you go to craft them. Is there a red template showing when you’re trying to craft them? Are they not unlocked in the main crafting menu? If you have nothing else in your inventory, do they appear in the quickcrafting menu?

  • You mentioned going to the island with the plane. Are you also trying to craft the Story Items to repair the plane? If so, there was an issue with the items not unlocking in the crafting menu for players. However in the past, they have appeared in the quickcrafting menu which players could use as a workaround for this issue. After the update to 2104 players have reported they are not appearing in the quickcrafting menu - if this is the case for you, please let me know.

Any additional information you can provide about the issue you’re experiencing would be greatly appreciated as this can help the team investigate this issue. I also completely understand how frustrating an issue like this could be and not wanting to do it over again - I will be sure the team recieves this feedback alongside the information you’ve provided.

Thank you.

Ok so i’ve tried everything you told me to and nothing happened, about the quick craft i’ve tried that before and i had nothing but basic stuff.
So i am really scared and so is my friend because i actually don’t have proof that we beat all of them bosses… And i must say i really don’t want to fight Lusca again.

So to describe precisely what happened, we beat each of them and a window suddenly appeared to tell us that we got the monsters parts but when i got the story menu (the little star) everything is locked, thought actually i didn’t have the good craftmanship level but it was not the problem.

Also i still wanna if the trophy “craft them all” is also buggy in coop or does it actually work?

Iam also experiencing this bug i beat all the bosses and i cant craft any trophies or airplane parts i dropped everything from my inventory and tried pulling up the quick craft menu and nothing appears on screen just the sound like denied.

@Dokrayn Thank you for those details and for the screenshot showing your crafting menu. I will alert the team that both the trophies and the plane parts are uncraftable for you. I know there are team members working on trying to find a fix that wont require players to beat the bosses again, but I can’t confirm if that will be the case at the moment as they’re still investigating it.

The story items being locked will likely affect “Gotta Craft Them All”, as well as this players are struggling to craft and place items like shelves which will affect the achievement too. I’m keeping the team up to date with reports from players so they can work to resolve these issues and ensure players can get the achievements.

@ImDabbing welcome to the forums, I’m sorry to hear this issue is affecting your game as well. Can you confirm for me what console you’re playing on and if this is occuring in a pre-existing save that was updated or a new save started after the update?

I’ve had the exact same issue where I cannot craft story items or trophies after beating the bosses. I’m glad to hear that they are fixing the issue. I’m also playing on coop so maybe it has something to do with that?

For reference,

1 Like

Hello, I’m having the same exact issue as original poster - except that when I defeated the bosses I was of the correct crafting level to craft the items (probably doesn’t make a diff)

I’m playing on PS5 on a 60-day online session with my brother (also on ps5 - I am host) and we have defeated all 3 bosses, with 1 boss recently after one of the latest updates. So it’s a pre-existing save that was updated.

Prior to the update, I do remember being able to craft the aircraft parts in my quick craft menu. After the update, I seemed to have lost this ability. And without realising it, we went on to take down the last boss. I then could not craft any item, nor any trophy.

Pls pls let me know what needs to be done because we have put many many many hours into our session, had a lot of fun and would like to see if off properly.

I also have this issue on ps5 pre existing save. Online session I Just finished loading everything in to escape. For the trophy’s I went to craft the 3 boss parts but all are locked. I also recall being able to craft them at an earlier point in time. I went and killed Meg again and it said the parts unlocked but again nothing is appearing.

@Grimsim, welcome to the forums, and thank you for adding your information to this post and for providing that screenshot. From your screenshot I can see you’re on XBox and I will confirm for the team it is definately happening on both consoles for multiple users.

@adamos Welcome to the forums, Thank you for reporting this info, I had responded to both yourself and @Wombat1981 in the other thread you both commented in. But I will add the aditional information in these posts to my report for the team.

Unfortunately with the quickcrafting workaround no longer working there is no known workaround at the moment for this issue. However I know team members are still actively working on it.

Thank you.

1 Like

@Clare your dev team [edited -Clare] to patch the work around instead of actually patch the problem. Made the game physically impossible to beat now . Way to ruin your own game. And I’m reading this has been an issue for over a year now ?? [edited -Clare].

1 Like

@Ltanner5, I responded to your post in another thread also, and as I mentioned there, I understand this issue is very frustrating for players - especially as the workaround is now no longer working for this long standing issue - and while we have no issue with players sharing positive or negative feedback about the game itself. Name calling or accusations towards anyone in the community including the dev team are not allowed and go against our Rules and Guidelines - Stranded Deep. As such I have edited your comment.

The team are currently working on and testing the fix for this issue, it is one of their top priorities and any further updates on the fix status will be posted here: [Known Issue][PS4/XB1] Crafting Menu Reset / Story Items Locked

The fact that you have a game breaking bug that literally will not allow you to complete or finish this story line of the game and then patching the only work around is the most pathetic attempt I’ve seen from a development team since Battlefield 2042… there should be a full refund issued for this game this is unacceptable

I personally will never buy or play another game made by this development team 60 day in game character, in a game that is not completable… this is a failure of epic proportions

Hi WraithVorn, welcome to the forums,

I understand that this issue is a frustrating issue, especially with the workaround no longer working while the issue persists - which I do not believe was the intention of the team.

In case you have not seen it, this is the latest update on the progress for the fixes for recent issues: Message from the Team - Console Update Progress Info