Ps4 multiple bugs, unplayable

create an island no longer works. granted it was already limited to begin with, but now you cant even cycle locations of where you want shipwrecks, resources, rocks, trees, etc.

online, seed 666 (amongst others i have tried), no interactions - cant save at hut or sleeping bag, can’t cut down palm trees, cant release sail on boat, pretty much unplayable.

multiplayer - good luck even connecting to server, then when you do, constant flux of connecting when someone tries joining.

i enjoy this game, but i cant even enjoy the offline version anymore.

Hi mwalluk, welcome to the forums,

I’m sorry to hear these issues are affecting your game. I’ve responded to each below.

  • Island creation. I have submitted a report to the team on this issue. There is no workaround that I know of for this issue.

  • No interactions. I have a post on this issue here [Known Issue][PS4/XB1] Loss of interactions that I recently updated. The team believe they have found the cause of the issue and are now working to resolve it.

  • Multiplayer - what region are you in? I know the “USA, East” region is having some issues with connections as well as choosing “Auto” if you are in that region. Have you tried changing your region when trying to connect?
    Please also let me know what your NAT type is and if you are typically hosting or joining a game?

I understand how frustrating these issues can be and any extra information you can provide on your multiplayer connection issues would be greatly appreciated as it can help the team to investigate.