Editor doesn't work after latest update. But

The harvest islands I created before the patch are still able to be placed.

:slight_smile:

Hi DanBurke420,

Can you elaborate on what you mean by “The Editor Doesn’t Work”? I saw mention in another thread that items are missing from custom islands, is this what you are refering to?

When you try to use it nothing shows when you place it but ships really. And I mean nothing. No trees, no cliffs, no animals or anything. Then when you save that’s exactly what you get. An empty island. Seems some rock formations spawned under the water but as for the island itself. Its completely empty except for birds and bats. I didn’t try using or placing anything that didn’t provide resources. However, I would assume they also won’t show… (Banana plants, trees without coconuts etc)

Its completely broken.

Also it should be noted: That my old custom islands were able to be used. But again… The snake’s failed to spawn. Other than that, everything else seemed to be working like a default island would.

I didn’t test these to see if the glitch kicks in after 4 hours or so… But I can only assume that it will. I can test that if you’d like.

editor works fine for me, I can make a new island still and all items are there for me even after the bug

I’m curious. What platform are you on? When I tested this it was to confirm it didn’t work. And I got the same results. Nothing shows on the island as you add things.

I’m on the xbox1 S.

This is another case where I’d like to see it being done, so I can compare notes.

Also we were testing this on islands created as low as possible because everyone was saying things lasted longer closer to sea level.

Hmm. I’ll try this again with a taller island when I get a chance.

on ps5 i cant randomize locations for cliffs, trees, resources, etc in creator. for instance, click X multiple times to have the cliffa move to a randomized location. everything stays in same area it was originally placed.

ps4 for me, I didn’t really mess with the size at all just left them at normal starting size, and placed until it said I had no space lol, but im also not making any custom islands on this save file, just finding that it glitches at march16th at 2am for me no matter what I do, I can stand still in one spot the whole time and create nothing, and at 2am it glitches out

Just to verify… I created a new xbox account…I created a new game. I played long enough to create a save shelter. I went to the main menu. I clicked the cartographer. I clicked new island and created a medium size island. I chose a medium min hight. I chose a medium max height. I then proceeded to try to add basically 1 of everything with the exact same results. Nothing shows after placing in the map as you build. I then named it and gave it a description and saved. I went back in game and saved just one more time for good measure. I went back to the main menu and clicked the cartographer and then chose world editor.

I clicked on an island not in red and replaced it with the new island I just created.

I went back into the game and then swam to this island. Its absolutely a barren wasteland. No cliffs, no trees,no animals. Nothing spawns but the ship wrecks, birds and bats.


I just tried this all over again and it worked. I’m at a complete loss of words now.

Correction I didn’t swim out to check. …

Nope still an empty island. So I went back to the main menu. I opened the cartographer. Where I was able to on the this attempt to see things placed on this new island I created They show in the editor still as being there.

I went back to the main menu and made absolutely sure the world updated with the new map. I then check it in the cartographer. The trees placed were still showing as being placed. So I closed and went back into the game and swam there again.

Nope. Everything is a barren wasteland even though I can now open this new island up in the editor and see things on the island in that world in save slot 1. They have placed in the editor and they are not spawning in game.

(I have changed things slightly and made sure the world updated with the new island and went back and forth from game to the cartographer. The game says its out if date. Ask to update to current version (which is normal) I click yes… Save…check editor. It shows island still with the trees I placed. (The only thing I’m changing a bit as I test this) I save over existing map…I go to the main… I click cartographer one more time for good measure and I get the map is out of date warning. I click yes to update it. I back out of it and I’m asked to be sure at which point I save again. I go back in game and swim to this island…and… This time it worked…

So I’m not sure what’s going on here. I literally take the same steps and sometimes it works and updates and sometimes it doesn’t.

[I was typing this step by step as I was doing this.]

Hi DanBurke420,

Thank you for providing those details, and the image. I also really appreciate you taking the time to write out the steps you were taking as you were going. I shall share these steps with the team in the hopes that they can test and reproduce it on their end.

Just to elaborate if the island editor worked properly, why when designing an island can you not adjust placement of items, why can the console version not have the same island editor interface as with the pc

There is an issue with the item placements not randomising when being reapplied in the cartographer that I have submitted a report for. For the cartographer itself the island customisation was set when the port was being created - I unfortunately do not know the technical details behind this. I do have a request list for the team and will add your comment on the island creator as feedback to it.

1 Like

Ty I appreciate all the time and hard work you all are doing

1 Like