[XB1][Latest][Crafting] Unable to build on raft

Crafting placeable items; container shelves, chairs, light poles onto the raft glitch through and attach to the underlying pixels.
When building over water, items glitch through the raft base and attach - floating - over the water (pic included).


Animals set to passive.

Attempting to build on raft items on a raft.

Console cache cleared.
Tried loading from save game.
Game restarted from scratch.
Tried online and offline play.
Tried with passive and default nature.
Uninstalled and reinstalled game.
Tried on different console.

Hi Farstrydr, welcome to the forums,

I’m sorry to hear you’re experiencing this issue in your save. Thank you for reporting it and for including that image of your raft.

Please confirm for me:

  • What is the dimensions of your raft?
  • What materials is your raft made of (base and floor)
  • Have you noticed this occuring for all raft floor types, or is it specific to the metal floors? As you mentioned you started the game again from scratch, does this mean you tried wooden floors and bases also?
  • Do you have other items on your raft that placed correctly? Rudder, Sail, etc?
  • You mentioned items are placed floating if built over water, does this happen at all on land?
  • You also mentioned items glitching through the raft, does it appear that they are attaching to the base parts or do they glitch further through?
  • If it’s possible to see these errors via video it may help the team get a sense of what’s causing this issue (we cannot host video on the forums, but an unlisted Youtube clip or One drive clip can be helpful - feel free to DM me if prefered)

Thank you also for letting me know what you’ve tried to relieve the issue already.

Thank you for you detailed reply.
I will try as many different raft types as possible over the weekend.

The present raft is a T shaped, 3+1. All buoys with metal base.

Back row, left to right:
Metal on Buoy. Cannot attach anything else.
Metal on Buoy; canopy; engine (no fuel).
Metal on Buoy; crate shelving, anchor.

Metal on Buoy; sail.

After connecting the first container shelving, the raft then become unusable for any other item to be built upon any section.

Attempting to build on the raft whilst on land would attach directly to the ground underneath. Ignoring metal and buoy.

Building crafting “benches”, fire pit, shelter, building foundations and pieces, will still attach direct to ground. They don’t float.

If over the water, item would attach - floating - above the water. This occurs regardless of the raft being present and container shelves have been built a few inches above the water.

Worth noting that existing items that should block building still perform that function. No “morphing” of one item into another seems possible.

I shall post some video footage once I get back to my Xbox this weekend :blush:

Hi Farstrydr,

Thank you for that info. I will keep an eye out for any messages containing video footage if you have time to take some.

In the meantime I will report your findings and experiences with this issue so far to the team.

Thank you again

FYI, you can’t place crafting structures like water still or fire etc to a raft, so don’t bother.
that’s a pc mod only
the only things that can be built on a raft are the raft-specific floors, the things in the raft building tab (canopy, rudder, anchor, sail, boat motor) and the container shelves and light poles.