[Steam][][Multiplayer] Multiplayer unplayable

I have tried to play the game with my friend but soon after 10-15 minutes or so joined player has too many glitches so that it is unplayable. Second player starts to see stuff like floating crates and tools. When sailing (life) raft appears half submerged. Also stuff made by host player doesn’t appear to joined player. I was hosting the game and built a raft but my friend couldn’t see it at all and walked right through it. When my friend hosted the game and built a water still I couldn’t see it. So we both have tried to host the game but it’s the same glitches for the joined player. Game was playable before but latest patches seem to have broken the game quite badly for us.


Correction to game version that appears to be We also tried to use older game version by selecting the version that had worked previously from game properties in Steam → beta but for some reason older version also has same problems. Not sure why, maybe game wasn’t fully reverted to that version and still used something from latest version.