Ps4 trophy bug "Call me Ahab"

hello guys, i need help. I just killed the 3 bosses in the game and made their trophies and the “call me ahab” trophy didn’t come. but these items were the only ones I needed to get the “Gotta craft them all!” trophy, and it came normally. now I got the trophy I won after that.
can someone help me or give me a solution
my psn user: [removed -Clare]

I made another save, killed the 3 bosses and the bug continues

Hi hikenn98,

Thank you for reporting this issue.

Unfortunately we do not have access to PSN accounts so we cannot unlock this for you on our end. I removed your PSN username from your post in the interest of privacy for you.

I’m sorry to hear “Call Me Ahab” it’s not unlocking for you in both attempts. I will inform the team of this issue occuring.

Please let me know:

  • Are you playing on version 2078?
  • You mentioned “gotta craft them all!” unlocking. Did you receive a notification in game for it? Some players have mentioned in the past that they experienced a trophy unlocking but didn’t get a notification. Did you double checked the trophy list on your PS4 after both attempts to unlock this trophy?
  • Please let me know what settings you are using when playing.
  • Please try clearing the cache of the console by shutting down and unplugging for 2 minutes before reloading the game to see if the trophy then unlocks for you.
  • While it may not be a factor in what happened, please let me know what order you killed the bosses in and if you used the same order both times. If you can recall, please also let me know what order you crafted the trophies in too.

Thank you again for reporting this to us.

yes i’m playing on version 2078
I always check the trophies lists and it hasn’t arrived yet.
I didn’t change any settings when playing the animals, I put passives and my character is only a woman.
I cleared the cache and the trophy still hasn’t come.
both times I killed in the same order, eel, megalodon and squid
there is a save that i saved before creating the trophies so i can create them in any order, and i have another one that they are already created
on reddit there are some people with the same problem, someone said the solution was to make them on their main island but i haven’t found it yet.
thank you very much clare

1 Like

Hi Hikenn98, thank you for responding so quickly, I’ll include all this information in my report.

I know a workaround for the “Gotta Craft Them All!” trophy was crafting things on a home island or the starting island. So there is a chance this may work as a workaround for this trophy too. If you do try these, please let me know

Thank you for also letting me know you’ve seen other players note this on Reddit. I’ll add in a comment about that too so the team are the aware it is occurring for a number of players.

1 Like

I just tried to go to the initial island and the trophy still didn’t fall.

1 Like

Thanks for letting me know hikenn98 I appreciate you trying this as a workaround. I’ll inform the team that this does not unlock the trophy.

You could try hanging them on a hook in case that makes a difference?

1 Like

One of the things I tried was exactly that, if you have more suggestions I’ll accept, because I don’t know but what to do.

hello clare, i followed a tip from reddit
and monster trophies really could only do on the first island
I hope this feedback helps the game to fix this because even with the bugs I love this game
and another thing I changed the sequence I made the bosses

1 Like

Been having this issue as well. My friend that I was playing with got it though. I am the host
Also we just beat the game and neither of us received the “out of the frying pan” trophy

1 Like

I managed to solve the “call me ahab” see the comment above
“out of the frying pan” never bugged with me, I’ll do some research and see if I can find a solution for you

Thanks for the update hikenn98 - I’ll let the team know and will make a note of it as a workaround for other players too.

Hi Newfie_Knight, I’m sorry to hear these trophies are acting up for you as well. Can you let me know what the settings for this save were and what console you are playing on? I can pass them onto the team which may help them in replicating the issue.

Please also let me know if any of the suggestions such as clearing the cache of the console or checking the trophies on your console list rather than in the game made a difference for you.

Hi @hikenn98 and @Newfie_Knight,

Quick follow from the team on this, a team member that was looking into this said that “Call Me Ahab” is unlocked when a player places the three trophies in their backpack.

When you were having issues unlocking this trophy, was there any point when the trophies were in your backpack but it didn’t unlock?

I want to determine is this is some confusion over the trophy that can possibly be looked into on our end, or an issue where the trophy is failing to unlock under those conditions anyway.


It did not work by putting them in my backpack

Thanks for letting me know HazyKinkajou. I’ll let the team know there is definately an error occuring here for players.

Hi Clare,
Unfortunately I am experiencing the same bug. This is the last trophy I need, and I don’t have a save from before beating the bosses. I really don’t want to start a new game and play through 50 days again.

I killed the squid last and crafted the trophy on another island (not my base or center). I tried putting them in my backpack or on the wall, and saving/loading again. The trophy didn’t pop.

Hi @Elessar8, I’m sorry to hear this issue with Call Me Ahab is affecting your save too. Can you confirm for me if you tried putting them in and out of your backpack on your starting island? Unfortunately so far other than crafting them on the starting island I have not heard of a successful workaround…

Thank you for reporting that you are experiencing this too and what you tried to work around it. I completely understand that creating a whole new save to get this trophy is not ideal for players and I’ll add your details and this feedback to my report for the team.

Unfortunately putting them in and out of my backpack on the starter island doesn’t work, neither is hanging them in the wall.
Is the team working on determining the cause of the issue?