[PS4][2121][Objects]Objects Floating & Disappearing

For the main post please follow the summary as best you can:
Feel free to edit and replace each section with your own info.

So prior to patch 1.18 for the ps4 objects would straight up disappear out of the boxes for player 2. But player 1 (host) could still see them. The only way player 2 could see them again is if player 1 puts them back in the boxes 1 at a time. Patch 1.18 rolls out and played for almost 5 hours not a single problem (other than my partner could not grab anything). Patch 1.19 comes out and basically reverts back to items missing, objects missing, some don’t load in (I would run past the same spot that player 2 would go by and I would see [insert any object] but player 2 would not).

I figure this is related to all of this and had my friend send me a screenshot: I think/feel the objects floating like this on the raft are related to everything else that is going on with the ingame objects.

Man, I was excited that I may finally finish the game but I fear that we won’t and abandon it. There are just too many bugs and has been a nightmare. I love the game but I just can’t deal with this.

Same here. So disappointing. It honestly worked for the 30-40 minutes we played the night of the update. I was so excited to get back into it! Ive already played through it several times and 100%’d it, but my bro hasnt yet so i’ve been trying to help him out with it. But last night and tonight its like everything was reverted back to the garbage dogshit game it was. Crates disappearing, random disconnects, trying to look into a crate and its empty then everything pops up outside the crate, items floating, items disappearing…… its just not fun playing a game that doesnt work.

this is happening to me too, I even created a post, the boxes are empty and there are still several visual bugs, and every time I try to play even buggy I am disconnected in 5 seconds or less.

Hi Bandana_Assault, welcome to the forums.

Thank you for submitting this report. From your report it sounds like this is an issue with desync between players and the crate contents. The team is still investigating this and I have a few questions below about your experience and setup if you don’t mind answering them as they can help the team investigate and work to replicate scenarios internally for testing.

Please let me know:

  • When you played without issue, was this a new save started after that update, or were you playing on a pre-existing save from the previous update?
  • What ISP and router are you using?
  • Do the same issues occur if Player 2 hosts a save? (please note if you have not tried this yet, it may take some time for the same issues to appear, if they are going to)
  • What is the NAT type of your connection? (this is in the Network Settings section of your console, if they are different, please indicate who is the host)
  • Are you on the same connection in the same household or separate connections?

Regarding the items in the screenshots floating. That looks like a part of the raft. Was this originally supposed to be in storage, or is this something that was placed by you but appeared this way for player 2 once construction was finished?

If you save a reload, does the raft part appear in the same place or the correct place for Player 2?

I completely understand how frustrating and disheartening these desync issues can be for players and appreciate any additional information you can provide.

Thank you.

Thank you for providing additional information and screenshots from your own game.

If you could answer the same questions I posted above for Bandana_Assault that would be very helpful. As each person’s setup and gameplay style is unique, the more info we have to help us find the common threads for these issues, the better.

Additionally, for your second two screenshots, Was the bundle of sticks supposed to be in storage, or were they floating in general?

And was the wood crate floating above where it had been stacked, or is there a fourth wood crate missing from that pile?

From your comment it also sounds like you’re Player 2 helping your brother, is this correct?

I do completely understand how this can affect gameplay and enjoyment of the game for players and any additional info is greatly appreciated by the team.

Thank you.

  1. “When you played without issue, was this a new save started after that update, or were you playing on a pre-existing save from the previous update?”

This was the same save since the introduction of co-op play on console so it has been a couple of years at least.

  1. “What ISP and router are you using?”

Comcast, 900 down and 20 up. RAX 120 Netgear Nighthawk

  1. “Do the same issues occur if Player 2 hosts a save? (please note if you have not tried this yet, it may take some time for the same issues to appear, if they are going to)”

Clare, could you please provide me step by step or what “player 2” hosting the save? Does this mean player 2 is the host? (just to be clear)

  1. “What is the NAT type of your connection? (this is in the Network Settings section of your console, if they are different, please indicate who is the host)”

NAT Type 2, PS5 sits in the DMZ so all traffic no matter what goes to it. Player 2: Hardwired, NAT Type

  1. “Are you on the same connection in the same household or separate connections?”

Separate connections. He lives just across the state from me. I have set the server to USA, East before with no change.

Prior to patch 1.18 and now after patch 1.19 for player 2 (non-host): Objects would float out of their boxes and the boxes would be empty. In both times player 1(host) can remove all the items from the boxes (because the host still sees them inside the boxes) and put the items back in to fix for player 2 to see the items again to use.

The screenshot I took of our boat: This would also happen from time to time again Prior to patch 1.18 and now after patch 1.19 where parts of the boat would either be missing or overlap (as seen in the picture). We can reload the save and it will fix itself.

Here’s the issue with all of this and I guess this is where our frustration comes from: This game has been out since 2020 for console. My friend and I have been trying to play this together since the intro to coop which was in 2021. The running joke is that this game will never be finished (I’m sorry). These workarounds that I explained were fine for the interim but it has been a long time and we simply just can’t keep “workarounding” because we do have a ton of items accumulated. I hope that didn’t come out rude and I know it isn’t your fault Clare. Please let me know if there’s anything more you need from me. I will be happy to help.

Clare, I know for my player2 the items were just floating out of the boxes.

Hi Bandana_Assault,

Thank you for taking time to answer my questions and provide additional details.

Regarding the question around Player 2 hosting, my apologies for my phrasing not being great on that question. What I meant was: If you swap who is hosting, so player 2 hosts a game, rather than you, does the issue still exist with that setup?

This would mean creating a new save as saves are maintained on the console of the host. Because your game is a well established save, there is a chance that these issues may not appear in a new save anyway until it reaches a more established state.

As this is the save you’ve used since co-op was released, do you regularly cycle islands to add more resources to the game? While I know the team are working on the issues with crates experienced by player 2 in a multiplayer game, and it is a common report among various levels in-game days played in Multiplayer, I also know that cycling custom islands and adding more resources to a game or your base island can have an impact on gameplay too so the issue with your raft at the desync of crates may not be related. However I am not a dev myself so I cannot say for certain.

If you have a lot of loose resources on your island this can also have an effect on gameplay, however I completely understand that with player 2 being unable to access crates, that leaving items out of storage is a common way for players to workaround this.

As I mentioned in my last post, I know how frustrating and disheartening issues can be and I appreciate your feedback at the end of your post.

I will pass on all of the additional information and feedback you’ve shared onto the relevant team members and if they have any further questions about your save, I’ll post them here.

Thank you.

Clare here is another example and this time with two different friends of mine. Again playing on wired connections and you can see boxes floating, objects floating above boxes and boxes empty. They also tried what you suggested and had player 2 host with the same results.

1 Like

Hi Bandana_Assault,

Thank you for sharing further examples of the issue you reported. I will pass these onto the team.

I was discussing the previous images you had shared with the team and they were wondering if you would mind sharing a copy of your save file with them so they can have a closer look at the issues reported.

The team unfortunately cannot fix and return individual files, but your save would be used to investigate the issues you’ve described, help them replicate the issue internally and hopefully fix issues like this for players as a whole.

If you’re happy to share your save, please use the following instructions:
To access the file:

  1. Turn on PS4

  2. Insert an External USB Drive into one of the 2 USB ports on the front of the console.

  3. In the main menu, go to “Settings”

  4. Click on “Application Saved Data Management”

  5. Select “Saved Data in System Storage”

  6. Select “Copy to USB Storage Device”

  7. Select Stranded Deep

  8. Select all files and press “Copy”

  9. Wait until transfer is complete

  10. Remove External Drive

  11. Zip up all files copied to USB drive including “.bin” and “Profile” files

  12. Host the files on Dropbox, Google Drive, OneDrive or similar, and DM me a link to the files. I can then upload them for the team.

Thank you.

I will get started on that today and send that over to you. I would also like to note that it doesn’t happen right away. That it does take some playing time to replicate. So when you reload the game everything can be normal for a time and then it happens in game after a time. [Again there’s no timetable as it seems to be random]

1 Like

Thank you for letting me know Bandana_Assault, I’ll be sure to include that info for the team.

I sent you a message. Sorry for the delay. Things got a bit hectic on my end but I found time this morning.

Hi Bandana_Assault,

No worries, I see the message you send and will get those files over to the team asap.

Thank you for taking the time to send them. If the team have any follow-up questions about your save I’ll post them here.

A post was merged into an existing topic: Console update 2121

Hi @Bandana_Assault,

Thanks for sending over your save file, much appreciated. We will investigate asap.

Could you give me any insight into your play style? “We both travel on our raft to loot an island and bring everything home” or “I travel to an island while my friend stays and cooks our food.” etc.

Have you noticed any pattern to the disconnects or desyncs? For e.g.: Does it happen after travelling to or from an island, after using a particular item, after saving at sea vs on land, or after the client joins the game in-progress instead of the lobby? I’m hoping we can find some clue for a test scenario that we may have overlooked…

Thanks for your patience while we work on fixing this issue. There have been many oversights and issues that we have been working hard to address since we took stewardship of the console version. This issue is our number one priority and we’re continuing to dedicate time and resources to reproduce it. Unfortunately, the local team here in Aus, our QA team, and team members in Europe have not been able to reproduce this issue once in 18 months :frowning: We are noticing a pattern forming of reports for this issue being from players in the US using certain ISPs and we recently learned that there can be conflicts with certain ISPs and the third-party relay servers we use for online co-op. We’re looking into what we can do about this.

Some times it would happen after a desync but other times it would happen at any point in time (without a desync or disconnect). I know my friends who played them as well said they never were desynced and had some items floating out of the boxes and not appearing for the other player.

1 Like

Thanks. Your save file helped us fix a few desync scenarios. One issue I found in your save file is that the ‘Clay Bottle’ and ‘Leather Flask’ servings are not synced when they’re stored in the quick-access menu. If player A then drinks or empties the bottle it can cause a desync and disconnect. This is fixed in the upcoming v2126 patch.

We’ve also fixed a lot of other desync issues in v2126 related to clients joining in-progress games. See the patch notes for the full list when the patch is released.

1 Like

Just some feedback for you guys: The game plays 200000000% better. Like what a completely positive gaming experience we had last night. I think we got more done in the hours spent because we weren’t fighting the game. There are some small bugs to fix and I did report those but that’s basically all we experienced so far which I mean this has come a long way. Thank you guys for continuing to work on this.