*[PS4][2111][Crafting] Cannot place raft items*

Hello, have noticed a bug that makes it impossible to place items on my raft at any position. The item will snap into the target position, but remains highlighted red and will not allow me to place.

Have created a big dock to pull my raft up onto while I construct it (this is to avoid ocean waves shifting the placement of items, but that is another topic) and have noticed I cannot place a canopy down. The error for this is “too close to another structure” which is possibly from supports stretching down to raft base and touching the dock itself.
However decided to move onto sails and 1st sail went down just fine, no notifications. When placing 2nd sail down it was fine but suddenly became red highlighted no matter where it would snap to on my raft. This however give the “there is something in the way” notification message.


  • The work around solution for the canopy was to throw raft into water, or leave it hanging off dock. This removed the original error, but start having same problem as sails.
  • Noticed for my sails it would stay highlighted red if moved over an already occupied space at any time. So if while placing my 2nd sail I were to even glance at where my 1st sail was with it, it would snap to there and become red highlighted until I cancel and try again.
  • While working in the water my raft drifted far enough from island eventually nothing could be placed on raft (would not snap into any position) which pretty much means you can not make changes to raft configuration while out on the water. That makes sense to me, would not want to risk working on my raft out in open water, but might be related.
    -Raft is full 5x4 rectangle made up of tyres base with plank flooring.

Ps4 player also just to add to this, iv had problems the same, i used to put 2 engines on the back of my raft with an anchor in between them, thats not possibe now since the update, nothing is in the way but it says it is

Making Raft in general since last 2 updates has been abit of a feat of its own.

You put it in water… get a blockage. (Fish seem to count as blocking, as soon as they swim away I can place XD)

I used to place on crates, that seems to trigger it more often now.
At Best, I’ve put my Raft on Land, over a Hill, so spot I’m working on is way up in air… have had less issues.

Hopfully they get a chance and just let us snap pieces, even if theres small collision. Raft Launches across map… oh well, It’ll be funny, then I reload my save. XD

1 Like

Hi Zillox,

Sorry for the delay in responding to your report. Thank you for sharing these details with me. And thank you to @Breckabick and @Sera67 for your input also.

Would it be possible to get screenshots or a video (would need to be hosted on YouTube or similar) of the issue and the setup you have of the dock?

I’ll also check with the team if any of the model colliders may have changed or had rules adjusted recently.

Thank you.

1 Like

Just to follow up, I checked with the team, and they have tried to reproduce it today but have been unable to do so. If it’s possible get get footage of the issue if it’s still continuing, that would be great.

Not being able to add to the raft when away from the island, is however, by design.

I’ll give it a try on ps5 when I get a chance. (got some yard stuff to do with spring being here and all)


I have tried to put a few photos together to try and show the position of my raft, position of canopy, and placement problems.

Positioned my raft to sit on some building structures with corner hanging off ground

The allowed canopy placement is allowed when positioned right the first time (Canopy Position 1a). However when I move it across it snaps into position over a foundation it is “too close to another structure” (Canopy Position 2a). So deciding to go back to position 1, the error continues but instead just says “there is something in the way” (Canopy Position 1b). The solution is to cancel building, try again but this time “DO NOT LOOK AWAY!” and it pops in no problem (Canopy Position).

Also took some screenshots from attempt for sails, which did not require as careful positioning of raft to avoid ground collisions.

The sail does not snap into position, but hover it close around an existing sail, or where the player is standing on the raft, and it becomes red highlight locked giving error message of “something in the way” on other open positions. However oddly enough if placed at same location as a “light hook” this problem does not happen, and the sail can still be placed in open positions without having to cancel and try again

Example of before and after hovering sail near an occupied spot. This occurs on multiple parts of raft that could hold a sail if placed down correctly on first attempt.

Hi Zillox,

Thank you for taking the time to share those screenshots and for elaborating on your experience. I will forward this info onto the team to ask them for their thoughts and if they have any additional questions I will post them here.

Thank you again.

Following up to say the team took a look at the issue and believe they have found what’s causing it based on your descriptions and screenshots. In their testing they believe it’s possibly caused by an item ghost overlapping something else which would turn it red, and it’s not turning back again when there’s a free space.

This can obviously become more difficult to workaround as your raft fills up but hopefully confirmation of this is whats happening may help you to workaround the issue while the team work on fixing it.

1 Like