PS4 [2009] trophy bugged

After the update I decided to start to platinum the game. I have planted all farmable plants (including yucca) for the “Who needs the sea anyway” Trophy and it’s not giving me the trophy. All on same island

Hi Loreweaver,

Thank you for reporting this issue, I’m sorry to hear the trophy has not popped for you.

Can you confirm for me if you planted each in individual farming plots or if it was the same plot cleared out and then planted after the first seed grew and so on?

EDIT: also, after chatting to the team could you confirm if this was all on the same island sequentially or over time and/or on different islands?

Same island and over time

Thank you, if possible would you mind trying individual plots planting each one after another?

Sure. I also want to let you know that I waited until they were fully grown thinking that might have been the issue but sadly it wasn’t. And thank you and the rest of the team for the swift responses and help. I’ve reported bugs in other games and never got any reply. You guys are great and it shows that you really care about your fans. :blush:

Thank you so much for your understanding while we work through these issues - It’s greatly appreciated :slight_smile:

I shall keep an eye out for any updates to this post and thank you for confirming you also waited for them to grown the first time too - I’ll add it to my report!

I planted them all at once and still no trophy. Have waited for them to grow again and still nothing. Going to try and move the crop plot to the middle of the island and see what happens and I have them on the outside edge on the beach. I’ll keep you posted

I appreciate you trying different methods out and letting me know how you get on Lore, if the team have any more suggestions I shall be sure to share them too

Not been able to test. My son is sick. I’ll test when able

No rush at all Loreweaver! I hope your son feels better soon :slight_smile:

Have tried everything including starting a new save thinking it my main save was just bugged but still no trophy. Even went so far as to make sure no other plants were growing wild on the island. Also, can confirm sharks clipping into the terrain, just got bit and drug from a goblin shark that I watched go into then out of the terrain. As for my son, he’s feeling better. Wife and I noticed he’s cutting his 2yr molars. Thank you for the concern.

Aw no, teething is never fun! Glad to hear he’s feeling better though.

Thank you for that detailed update and giving me a rundown on what you’ve tried and any extra checks you did. I’ll update my report for the team. We did a quick trial run and didn’t find an issue on our end but there must be something more here (or it doesn’t effect everyone).

And of course one final check that you’re using an Aloe, Ajuga, Kura, Pip i, Potatoes, Quwawa and Wavulavula along with the new Yucca?

I too could not get this trophy with an existing save so I started a 2nd save with a new world and I was able to get the trophy to pop. I planted all 8 crops as you noted above.

Thanks for noting that NLGpro - this means the issue may be with saves that were updated. I’ll let the team know.

Yep. All plants planted. Even tried 2 of each with no luck

Thanks for the update Loreweaver, I’ll update the team as soon as I can.

Logged on to work on my base a bit, trophy popped up after I harvested 2 yucca plants. I dont know why but I guess maybe because I hadn’t harvested those 2 yucca plants in awhile it didnt recognize I had em planted??


First of all - I’m glad you got the achievement! But something I want to keep an eye on for sure. Thank you for letting me know!

Hi @Clare,

I thought this might be helpful. I have been having the exact same issue getting this trophy and have tried many things and it just popped for me:

What I tried that didn’t work:

  1. I originally had 11 potato plots (made of corrugated scrap). I replanted 7 of them with all the other plants, plus I added 4 new plots for the Yucca
  2. I added 8 new beds that have never been planted on my home island
  3. I went to a new island and tried #2.

Note: this was all done on a previous save from before the 2009 update. Not on any custom islands. On the PS4. I did not try with a new save.

What Worked:
I had actually given up on the trophy and had been away from my island exploring for several days. When I got back, all my plants were dead (the original plots from #1 above). I waited a couple days for rain (that will usually bring them back to life) but it didn’t work this time. I replanted all 15 plots using the spoiled plants from those plots (except for the yucca, I had to get new fruit). This included 4 potato, 4 yucca, and one of everything else. Once I planted the last plots (Yucca). The trophy pooped for me. I didn’t even have to wait for them to grow.

Thank you Kate for that detailed description of your experience, I really appreciate you adding to this. I’ll pass this onto the team too so they can use it in their investigation and own testing :slight_smile: