[PC-Epic] [Bug Joystick]

The controller doesn’t activate, I have a joystick and it just doesn’t activate in the game in any way, I wanted to play local cooperative mode but it doesn’t work.
I wonder if this mode is disabled or is it a bug?

Hi MatheusMH,

Is this issue also present in the single player mode or just in coop?
In coop you may need to assign to P1 or P2 in the input settings.

Can you please provide the following:
Detailed system specs: including operating system, CPU, RAM and GPU models.
Controller model may also be useful.

I have same problem. Already bought new pad and nothung changes

Hi darulek,

Is that in single player or only in local coop?
Can you also provide the specs as above please?


To echo Night_Snake’s suggestion – you need to go into the input settings and assign the controller to a player – P1, P2, etc…

Intel core 2 duo e8500 3.16Ghz
Nvidia geforce GTS 450
Ddr4 8 gb

When i plugged two pads, game detects them in input settings. But neither of them works

Double checking – Does it say NONE or P1 next to the controller name?

Keyboard and Mouse p1
USB joystick p2
Generic USB joystick p2

When i want to play coop

Even i single When i changes to P1 pad still not working

What joystick are you using? Do you have the correct drivers installed for it?

Speedlink thunderstrike - Windows has drivers for it
Esperanza eg102 - drivers installed, status “working correctly” and responds to movement

So they works correctly

Ryzen 5 3400G with Radeon Vega Graphics, GPU Vega 11.
Ram : 8 GB
Controller: x360 Controle Emulator.

“Even i single When i changes to P1 pad still not working.”

yes, in mine it is like this

For future persons who may not be aware of how to set up the player 2 device, click:
Then see

I might suggest that even if your controller seems to be plugged in, assure that the keys are mapped correctly when you scroll passed the “Controller” section

1 Like

That’s exactly the setting many of us use - and don’t get any response while the controller has its appropriate drivers installed and works in the Windows game-controller setup.

I looks like this is related to unsupported controllers (mine shows as “USB Joystick” [but that may be ok as it shows as USB Network Joystick in the Windows game-controller]).
Is there anything one can do to fix this other replacing the controller with a different one?

Note: I’m using Stable Build 0.76.01 from the Epic Store and Launcher. That version uses UnityPlayer 2017.4.36 (relative new one); would it be possible to get an update of StrandedDeep that get a newer UnityPlayer version (would that be 2017.4.40 [which likely only fix graphics/memory issues] or is an update to 2021 possible, too)?

Is this Controller bug more related to UnityPlayer (so Unity3D may provide some insights - fixes) or to StrandedDeep?

I’ve got myself a bunch of controllers to test and it seems like Stranded Deep currently only supports X-Input (I guess that means controllers that also work on the X-Box) but the “classical D-Input” ones don’t work “native” (even when they work fine in other games, especially older ones).

So as a summary: Stranded Deep only supports X-Input, if your controller does not support that either use a different one or emulate that (see hints below).


  • some controllers can be switched between those two modes (which is not the same as toggling between Analog and Digital)…
  • older controllers can be used as an input to an X360-Controller, to do this: use GitHub - csutorasa/XOutput: DirectInput to XInput wrapper (may need the old drivers of the controllers to be uninstalled) and ViGEmBus (linked in the previous linked page, new users can only post one per post)
1 Like