[PC] [0.90.00] [CO-OP] Sync Save/Sync World Freeze WITH WORKAROUND

Summary
When attempting to load into a co-op game, oftentimes it will get stuck on Sync Save 0%. This happens if both players are in the lobby, as well as if the host starts the game and the co-op player joins.

Seed
ALL

Settings
No

Steps
Joining a co-op game in progress or in the lobby.

Extras
-Have you tried reloading your save, game or PC? Yes
-Have tried reinstalling the game? Yes
-Is there anything else you tried to alleviate the issue? Yes, see below.

WORKAROUND FOUND

Through testing, I can confirm that if the HOST of the lobby starts the online session alone, and the co-op player joins AFTER the host has had the session running for at least 60 seconds (as in, they’re spawned into the world for 1 minute), the game is able to load correctly. This is consistent, and has worked for us every time we have tried, and I have heard others have had success with this as well.

Edit: I’ve received feedback from several people about this not working, however I have not yet had this not work when I’ve done it. Of those who said this did not work, all of them did not have the host load into the world first. To clarify, the host needs to create the game, and then start it. They must be spawned in ON THE ISLAND for this to work. If they just sit in the lobby for one minute, it will not work. Make sure the host loads into the world completely, then wait 1-2 minutes after the host has loaded into the game and spawned into the world. Once that happens, after 1-2 minutes, have the co-op player join.

Small edit, I have had several people tell me since posting this on another thread that it works.

Did not work for me, waited several minutes before trying to connect, no dice.

2 Likes

Did the host sit in the world spawned in? To clarify, waiting in just the lobby does not work. The host has to be on the island for a few minutes.

For me this did not work I was in world walked around set a 3 min timer and me and my friend still got the sync save bug. He tried it on his end as well still didn’t work.

4 Likes

Did not work. Had the host join a game, paddle to the island, and proceed to start the normal survival process. at the 3 min, 5 min, and 10min mark we had the second player attempt to connect. This resulted in Sync Save Freeze. We swapped who was host and tried again, still the same issue.

When we tried having us both connected in the lobby this creates the sync world freeze.

To clarify. The first 6 attempts (3 each for each host) had the host connected. on the island performing normal tasks like eating, climbing trees etc. all resulting in sync save errors.

Sync world errors come from trying to boot the world while both are in the lobby. Sync save comes from an attempting to join an active server.

4 Likes

Still no update. Still unable to play co-op. Cannot do it with delayed joining. No Joining in at lobby either. Cannot do it with code entry or entry from list of servers. Can get the opening scene where you swim to the life raft to work together in Co-Op but when we get to the life raft, it cannot sync the world.

If you try any other joining method other then starting while you’re both in lobby (not on island) you get a sync save error/freeze
if you go through the lobby method its a Sync World Freeze/Error/

3 Likes

Yeah I have tried every workaround I’ve seen and still on both me and my friends side no dice.

2 Likes