Nintendo switch boss bug

For the topic title above, please use the format:
*[Nintendo switch ] Version 1.02.571
Boss despawning, and respawning for megladon over and over

I have tried to fight the megladon in 2 different games , I created a new save file from the original, and each time I go to fight the megladon it spawns then swims away , comes back then swims away, and continues to do this over , and over .

For the first game 13118408
The second #155584905

My game is in passive mode for both

I tried to turn passive mode off and respawning the megladon,

I’ve tried to close the game, reload it for both saves. I even tried making a new save (obviously) to see if it was just the file that was glitched. I did manage to beat the Big eel , haven’t tried to fight the squid . But when I was going to the eel in my first game , I saw the megladon glitched out in the sky (this was before I tried to go to the megladon in the first place as the eel was closer ) I didn’t think anything of it . But that maybe could relate to the glitch in the megladon? They were not close to each other on the map at all so the megladon being glitched in the sky at this area was very odd. But I continued with the eel boss then went to the megladon and I had come up with this issue. For the second game I went right to the megladon to see if maybe the problem from the first game was my own doing then I had the exact same problem with the shark respawning and going away .

Hi thisfilthyworld, welcome to the forums,

Thank you fro reporting this issue. The fact that you saw the Megalodon glitched beforehand is odd and could possibly be related. I’ll be sure to include in my notes for the Switch team.

Were any other settings in your save changed?

When travelling to the Megalodon are you doing so with the yellow life raft or once you built yourself and do you stay on the raft while the Meg spawns in and swims away or are you in the water for this fight or in another position?

I am staying on the raft and it’s a built raft. I’m going to try to go into the water this time . And making sure passive mode is off again. I still haven’t managed to find a work around . (Sorry I know it’s been months later )

I got the megladon to not go away

What I did is go back to the glitched sky sighting by the eel and I beat the meg then. Then I went back to its map location and so far it hasn’t gone away and is attacking me like regular . It’s still something that should be fixed anyways but I’m glad I got a way around it for now. I did kill the glitched version when I fought it (I’m surprised I was even able to trigger it) but was hoping I could kill the glitch version and get the propeller parts and such but not the case . Trying to beat the original map version now.

Hi thisfilthyworld,

Thank you for answering those questions for me and for the update on what workaround worked for you. I know a Switch update that was released today included a fix for issues with the Megalodon showing up with the Eel, so hopefully as this was tied to your workaround this issue is now resolved for players. I will make a note of your workaround in case other players report this issue.

Please do let me know if you have any further issues in your own save.