[MAC-Steam][0.80.01][Game] Game will not install

On October 9, 2021, I used Steam to download the new version of the game. I had not played since 2019. When Steam finished downloading, it tried to install and gave the attached error message.Screen Shot 2021-10-09 at 9.49.14 AM

For troubleshooting, I tried:

  • restarting computer
  • clear download cache
  • repair library folder
  • verify local files
  • disabling antivirus
  • disabling firewall

After each attempt, I still got the same error.

Actually, I am only assuming the version is 0.80.01 since that’s the last update I see listed on Steam. I can’t open the game to see what version it is. Is there a way to tell what version it is if I can’t open it? I didn’t see a folder with a version number on it anywhere.

Hi Thomwblair,

Normally you can see the game version at the main menu.
Otherwise the options.json in your save folder will tell the version you launched most recently.

Are you updating the game on Steam or going for a fresh install?
We would first suggest completely uninstalling the game and reinstalling.
Can you open other games without error?

It appears that error 4294956486 is a common issue among MAC users for many games.
There are some potential solutions on this page that may be of use to you

I can’t launch the game at all, so I can’t see the main menu.
In options.json the last game I played was version 0.65.05.

I tried updating the game via Steam and got the same error. So, I tried deleting the game and reinstalling several times, and restarting my computer after each new install. No luck.

I have no problems opening other games via steam.

You said " There are some potential solutions on this page that may be of use to you" but the link is not showing

I tried to follow the instructions on how to make an alias for the game via Terminal. Here is what I used in Terminal:
ln -s /Users/Thom/Library/Application Support/Steam/SteamApps/common/Stranded Deep/Stranded_Deep_x64.app/Contents/MacOS/Stranded Deep" ~/Desktop/

That created an alias called Stranded Deep. However, when I clicked on the alias, I got an error message: “The operation can’t be completed because the original item for “Stranded Deep” can’t be found.”

So, I tried to Fix Alias: I navigated to the package contents for Stranded_Deep_x64.app and set the alias to Contents/MacOS/Stranded Deep

That gave me another error message:
Screen Shot 2021-10-15 at 5.05.21 PM

I tried to figure out how to fix that error but couldn’t. Any ideas?

So, this morning I tried double clicking on the Stranded Deep executable file inside the Stranded Deep package and the game launched. However, after showing the intro “Stranded Deep” logo screen, it gave the following error:

Steam was running at the time and it was signed in with the account I bought the game with.

I tried making an alias through different means and this time succeeded. When I used that alias, it launched, but again hung and gave me the same error in the same place. However, some times after that, when I tried other variations of firewall exceptions, rebooting, deleting game, restarting steam, etc., sometimes it would show as launched in OS X’s Activity Monitor, but would say it was “not responding” and the game would never seem to launch, not even to give an error message. When it did this, I was able to force quit the game in Activity Monitor and try again. Sometimes it worked, sometimes it didn’t. I have no idea what’s happening.

Has anyone had any luck diagnosing this bug?