[Known Issue][PS4/XB1][Multiplayer] Player 2 cannot see items in crates

Hi Markenhouser,

The team are working on various issues that affect players desyncing, which can cause things like Player 2 to not see items in crates. While they have released a number of fixes that may help against this issue, a specific fix for this has not yet been released. If you continue to experience it in the current version of the game, please let me know.

Yup, just checked today. Game is still unplayable…

Thank you for confirming that Markenhouser. While I know the team are continuing to work on issues such this one, I will make a note to ensure they are aware players are still reporting it occurring in the latest version.

Hello,

Xbox One

I have two Player 2 issues, one being this crate one, although mine is a little different. I will start of that I am Player 2 just so I can refer to this as grom my point of view.

When I look into the crate, there is nothing there in the inventory but the items seemingly spawn within the physical crate. I can then pick the crate up and some of the items are there and can be interacted with (picked up, dragged, etc). Occasionally, Player 1 sees this as well but the inventory is visible to him. So there will be two of whatever item we have. I’m sure this could be exploited as a farming glitch but it just ruins the game for us.

This seems to be an issue with individual inventory where the game saves crate inventory as Player 1 inventory and does not transfer it to the incoming player. That is why, for me, it generates the items as if they were laying there, not stored. From my point of view, or my game, they are not viewed as Player 1 inventory either.

The issue is not present with Fires or Water Stills which hold Palm Fronds, or with storage on rafts (life raft at start of game or shelving) so I also believe it has to do with the fact that crates are moveable and not fixed. If the game could respawn them on load in as if they were a crate found in a ship, because those work fine for P2, it’d probably solve the issue.

Hi @Danger1523, welcome to the forums,

Thank you for reporting your experience of this issue from your point of view. I had originally reported Player 2 not seeing items in crates and the items floating outside the crates separately, but in investigating the team have found a relation between them as you have done, where both are symptoms of an overall issue.

While I do not have details on the progress the team is making on the fix for this or if their conclusions about the cause match yours, I will pass on the info and thoughts you have shared to the team.

Thank you again for taking the time to share this :slight_smile:

Checked again with the new update, items still floating out of crate and not in crate……game still unplayable….

I’ve noticed that sometimes, when we start the game, the glitch goes away and I can see all items in the containers. But more than not, the glitch is there. We’ve tried loading the game in different ways to see what might fix it but we haven’t found anything that consistently works.

For example, we both tried restarting our consoles, we both tried closing and restarting the game, the host tried to exit out of the game and waited for me to enter his “lobby” before starting his game. We haven’t figured out how to fix it yet but just thought I’d share some of the things we’ve tried.

The glitch seems to randomly just go away every now and then.

Thank you for sharing that information RoundTop, I will pass your findings onto the team.

[Edit: The team have requested more information which I’ve posted in a comment below, if you wouldn’t mind sharing what you can, I would really appreciate this additional info]

I’ll add this info to the very top post also…

The team are continuing their efforts and are looking into the connection between this issue, disconnects and desyncs in multiplayer. They have managed to replicate the issue internally but only under some only under some more severe connection issue simulations and are asking the community for more info regarding their individual setups and experiences as there can be a large number of variations.

If you’ve experienced this issue, if you wouldn’t mind answering the following, I can pass this into onto the team so they can continue to investigate this issue.

  • Have you updated to version v2107, and did this issue occur in the previous version for you?
  • Are you both in the same household using the same connection, or seperate households?
  • What connection type are you both using? (wired, wifi, 4/5G)
  • In your console network settings, what NAT type is displayed? If Player 2 and the host have two different NAT types, please confirm for me which is which.
  • What brand of router and ISP do you both use?
  • What region are you using for the multiplayer save? (if you’ve tried multiple regions please let me know if performed better than others)
  • If you experience disconnects in the save, have you noticed any common occurances that result in your disconnects - eg:
    • When travelling between islands
    • When on your base island
    • When when on surrounding islands
    • When performing a particular action
    • When you are further apart in the game… etc
  • Similarly, did you notice if the disconnects, desyncs or inability to see items in crates occured after…
    • X days had passed
    • After you had built or crafted a certain item or brought an item back to your island
    • When certain items were stored in the crates
    • After using crates from different islands / custom islands
    • After you gathered X crates.

And if there’s anything else you can think of that you feel could be relevant, please let me know.

Thank you

I have updated to v2107 and the issue only occured after i updated. Player 2 cannot see or interact with anything inside any crates.
Same household player 1 is wired connection and player 2 is wifi but 10 ft from router.
Nat type for player 1 is 2 and nat type for player 2 is 2.
We use Spectrum router and modem.
We use any region and private.
I cant believe this bug has been going on this long and there hasnt been a fix.