[Known Issue][PS4/XB1] Inventory and Tool Belt Reset (2074)

Most likely yes. We have been experiencing lots of disconnect and sync issues. Seems to maybe be less after the patch, played for a couple hours and only had one disconnect while on the raft sailing between islands.

Thank you for confirming that for me Arbotcat, I’ll update my disconnect report too.

Sorry I should have updated this post last week…

UPDATE 2021/12/06
Through testing the “Cleaning Up” phase issue, the team have found further clues in the cause of the inventory bug which they hope will lead to a fix being created and released to the community soon.

Thanks! It was quite difficult and nerve-racking fighting the bosses on permadeath, especially after a few failed attempts caused me to restart completely lol. I plan to overtake the current record of 421 days, lol. Fun fact: I have looted 23 of the islands on my world and all corresponding shipwrecks, and have only found one piece of duct tape. Had to finally deconstruct my boat motor to use the duct tape to make the speargun, so back at the sails again for now. Also to add a bit of information about the toolbelt/inventory bug that occurred in my other save. I haven’t loaded it up in a while, but since I accidentally saved with empty inventory and lost toolbelt it will likely not be redeemable. I was host on around day 60 when it finally happened, on a private multiplayer game. A friend had joined multiple times after a series of disconnects and watch desync issues. The common items that I had on my toolbelt with other reports I’ve seen were the speargun (in bottom slot) refined pick (in left slot). I had all 4 toolbelt slots unlocked. The save file that I’m using now was created before the patch was released, but I was careful to observe which items I placed in toolbelt. Up until now on the new file, I have only used 2 toolbelt slots (just in case the bug occurred I would still be able to make another 2 slots). Top slot being always occupied by a refined axe and right slot always a refined spear. I recently crafted the 3rd (bottom) toolbelt slot and placed a speargun in it, which I don’t plan to change for testing purposes. I have not had any issues so far. I know this comment is likely in the wrong place, but there are a few different topics about this bug and not sure if any were created in reference to playing on the Xbox Series X. Feel free to move this post elsewhere if there is a more fitting place.

Happy surviving everyone, hope this may help someone avoid the calamity :slight_smile:

1 Like

Hi @ArmchairTuna66 - I moved your post here as it has a lot of great information. If there are a number of topics and you don’t want to create your own, check out the “Known Issues” section of the forums as I often have topics there for gathering information :slight_smile:

Thank you for sharing that info!

1 Like

No they were already in tool belt

1 Like

Thank you for confirming Warlord13


Just wanted to report my observations when encountering a disappearing inventory as host.

Console: ps5
Game type: multiplayer as host
No refined axe
Toolbar 2 unlocked

Perhaps something of note, the island we spawned on had a small dilapidated lean-to with a small broken crate next to it. When encountering the inventory bug we noticed the crate was gone from that camp. Reloading fixed the issue as we hadn’t saved. Checked on the crate and it was back.

Just a thought but could the tool bug issue be caused by the ‘clean up’ phase because I see a lot of problems have occurred during the clean up phase on the loading screen

Hi @Rupert, welcome to the forums,
Thank you for reporting this and for mentioning that crate.I shall inform the team of this. Would it be possible to know the seed of this multiplayer save (you should see this in the cartographer of the save slot) and if you were on the starting island or a different one?

@HeavyZnDaBoys - I’m not sure of how closely they were linked, but the team did say they found something when investigating the “Cleaning Up” issue that would help them in resolving this issue. I think the biggest difference is the “Cleaning Up” issue primarily affected Single Player saves and this one is reported more in Multiplayer saves, but there could be something in common that lead to the teams discovery. Unfortunately I don’t know anything more beyond that comment from the team.

Update: I was able to re-craft the first toolbelt slot, but all the others are still locked. My crafting level is maxed. This is good news before all slots were locked. I’m not sure if this was patch during the most recent update?

1 Like

Im also on PS4, and noticed i could make the first toolbelt again. I also noticed you cant thereafter build the others. I also noticed that the story related items are also locked again, but as you can see, I definitely have some already

A post was merged into an existing topic: [Known Issue][PS4/XB1] Crafting Menu Reset

Hi @HeavyZnDaBoys and @AllKnowingAnorak - A player with a similar toolbelt problem noted that if they reloaded the game and tried to craft the first tool belt slot again, that it would unlock the second slot on their belt and so on. Please try this and let me know if it works for you.

@AllKnowingAnorak with regards to your crafting menu issue, I moved one of your posts to the relavent thread here to avoid going off topic - [Known Issue][PS4/XB1] Crafting Menu Reset - Thank you for reporting it and please see this thread for more info.

Yes, I can confirm that crafting the first toolbelt slot then reloading the game does let you craft the other 3. The recipe for the others is still locked, I juts had to craft the first toolbelt 3 times but it unlocked all of them.

1 Like

Did not work for me sadly, tried building it three times, I have the slots but the crafting menu is still locked

Could this be blocking my platinum trophy? Need to build all things and I’m sure everything else has been built

@HeavyZnDaBoys - Thank you for letting me know. I’m glad you were able to unlock the tool belt options.

@AllKnowingAnorak - Had you unlocked all toolbelt parts before this issue occured or are you crafting some for the first time? I have a report on locked items in crafting menus for the team. I’m not sure how the check for the Gotta Craft Them All trophy is done, so I cannot confirm this, but I have included it in my report for the team as potentially being impacted by these issues.

I think I’d unlocked them already, tbh I’ve given up.

A way to track what you have already built would be beneficial though

Thank you for that info AllKnowingAnorak. Regarding locked items, some players have found the quick crafting menu has helped in some cases to craft items locked in the main crafting menu. I noted this is the thread here: [Known Issue][PS4/XB1] Crafting Menu Reset / Items Locked

Regarding tracking items that have been built, once an item is crafted the colour splash behind the item icon in the crafting menu should change colour. However if the crafting menu is reseting this may not be displayed accurately for some players.