[Known Issue] Items, toolbelt and skills error

Issue Summary:
After updating to 2033, players may experience an error in their inventory when all items and their tool belt are missing along with sills resetting to 0. This is appears to only affect some saves and likely those created in 2009 where a player was using a tool belt. Not being able to craft a tool belt is also part of this error.

Workarounds:
There is no workaround, however if a player does not save the game, it is possible a fix may prevent the error from occurring when loading a save restoring the inventory and skills. While not ideal we recommend players do not save if this has occurred for them while the team work on a solution.

EDIT: If you have not yet updated your game, check out @alkewper74’s workaround directly below that worked for them. As always, please exercise caution when using workarounds with saves and consider backing up your saves first.

Being aware of this situation before i updated i thought this one while at work today, to do some tests and this did work;
if you disconnect the internet before updating and change game saves and save it. Then reconnect and update. This issue only seems to affect the game save you were on when it first loads. Unfortunatly i did try backing up my game save to usb that i intended it to affect and after restarting that game save it did once again.
I can also add that i did quite and reload the same save that was good after all this and it still didnt make me lose my belts items or skills.So it is just on initial load after the update.

1 Like

Thank you for that info alkewper74, I’m glad you managed to avoid it and that’s an interesting workaround if players haven’t updated yet!

So I just had this happen tonight and it’s the new save I just started a few days, to a week after the update. Loaded up my game tonight, on day 22, I had noticed my skills looked funny but I just thought maybe something had updated it and went on. Unfortunately I saved before I realized I no longer had my toolbelt and all the items that were there.

Now while this was frustrating, it made me decide to load up my original save (which I was stuck at the escape boat with not enough gas to get the gyrocopter home) which that save seems to be fine and is pre update. I’ll be sure to check it first thing next time I load though, but long story short I somehow managed to get back to my home island and that save is now alive and kicking again which makes me really happy lol.

Anyways, thanks guys! Stinks, but I’m not that upset about it. Bugs will happen, just glad to help throw some more information towards what’s going on with it.

Oh forgot to add, I meant after the Patch 5 update, pre 6. Forgot to include that.

Thank you for your understanding Desmonddark85 and for taking the time to share details or your experience with the issue. I’m glad to hear your original save is working well for your now!

Ive just loaded my game,first time ive played since the updates,my whole inventory of 9 boxes plus my 4 piece toolbelt is missing,after 320 days on this game.Is there a fix?This game is so frustrating with glitches.

Hi Cyberpunk488,

I’m sorry to hear this issue has affected your inventory too. The team are currently working to resolve this issue. Currently the only options in avoiding this issue are the ones listed in the post above.

Ciao siccome ho problemi di salvataggio (ovvero non sempre mi salva) se il gioco è disconnesso a internet può influire il salvataggio?

Translation:
Hello as I have problems saving (ie it does not always save me) if the game is disconnected from the internet can it affect the saving?

Hi Clau131313,

As per my last message, which might not have seen when you posted this - please post in english or include a 1:1 translation with your post so moderators can read your post.

Please also be careful when posting off topic, as your question is largely unrelated to topic of this post. I recommend posting a full report of the issue you experienced in the Bug Reports Section and I will do my best to answer any questions you have there.

I’m having this issue and have tried just about everything. The workaround suggested implies that it’s the initialization of the patch the first time it loads that corrupts the data in the save directed to in the options (or default) file. My experiences lead me to believe that this is not the case. Either way the workaround implies the old file can operate on the updated client without issue, it’s just a question of getting it into that state. I have a save file from 8/8/2020 before the update, it is the only one effected by the glitch. It happened to be the one that was directed to in the options file save. Given I had a backup of the file (in its original state before the patch) if I can follow the workaround with the save not present on my console, I should be able to get it onto the console and subsequently loaded without any issue, the main thing seems to be I need to not have that file be the one that is pointed to when it loads. I was able to accomplish this by selectively deleting the options file and my save slot 1, so when I deleted the application and redone loaded, it directed to the save file 1 day 0 when I launched, I then switched over to save file 4 (the save dated 8/8/2020) and the file is still glitched. This would imply the issue happens simply by running the file in the new client, not as a result of the initial load and which file is the last one used as the workaround states. I’ve done this both with the file 4 saved on the console but not the target save when first launching a fresh install, and without save 4 altogether until after my first launch, neither worked. I will retain the save dates 8/8/2020 in the state it was pre patch, but can I expect an update anytime to make this save functional? I set the game down (endgame) for a few months and finally went to pick it back up today, and this is what I found myself in. I’d like to resume the game and finish it, but I won’t be starting a new game.

Would you consider sending me a pre patched client? I’m 100% confident my file is intact as it’s exactly in the state it was when I logged off on 8/8/2020, before this issue arose, the persistence of the issue is solely related to the client version. Should I have access to the prepatched client I should be able to run the save. Additionally I could hypothetically implement the supposed workaround, but I don’t suspect that it will work. The only difference in what I’ve tried and the workaround as written is updating into a patch vs downloading a complete client already with the patch, it’s supposedly the launch of the patch that causes the issue, so but supposedly not persistently if you can avoid it the first launch. I’ve already avoided it by not even having the file on my system yet it persists. I haven’t seen anyone confirm the workaround actually worked, and I suspect it never did.

Welcome Wesn, my workaround did work, but unfortunately if you did install since then or have been connected to the internet since the previous update your console will have updated to the newest version of the game and will not be able to downgrade your version on console as playstation and xbox do not allow downgrades officially. i do still play daily and still test new theories every day.

You are going to have to provide more of a justification. Everyone (dev included) agrees that the save file in a pre patch state is complete and hasn’t lost the inventory nor the skills. We know it has to do with the client ver. In one way or another. Whether I’ve previously applied the patch is irrelevant as there’s no difference from updating then launching vs. fresh instal and launch. In both cases it’s the same new client launching for the first time. And the file is only corrupted when it goes through this launch according to you. My intact file was backed up before this update was pushed (months) so it’s a perfectly fine fine, if it doesn’t work it’s either the initialization as you said, or the client in a perpetual way. Given I’ve duplicated your scenario plus any other and effectively gotten my file past the launcher without it being the directed save, and it still doesn’t work, implies it’s the client acting perpetually.

Hi Wesn, welcome to the forums,

I’m sorry to hear this issue has affected your save. Thank you for sharing a detailed account of what you tried with the workaround and I shall pass these onto the team working on this issue. As the Console Team are still working on the next update, I unfortunately do not have an estimated release date for any potential fix for this issue at this time. Any information on updates will be posted in Console News and Announcements as soon as it is available.

As alkewper74 mentioned above, is is not possible to downgrade versions on consoles. We are unable to share individual patch versions to players or have alternate patches available in the way we would have on Steam.