[Epic] [0.90.00] [Co-op] Co-op game types not the same

In C0-op when a game is made. If I make it a creative game on my pc the person joining me will not be in creative. They can not set any thing on their side. The rules of the world are not universal. This needs fixed. One person should not be playing permadeath and and other should not be in regular game mode. But we see it with creative.

For the topic title above, please use the format:
[Platform][Game Version][Affected Topic] Post Title
For example: “[Epic][0.76.00][Audio] Sharks singing too loud at night”

For the main post please follow the summary as best you can:
Feel free to edit and replace each section with your own info.

Please provide as much detail of the issue and your experience with it as possible. Please also let us know how frequently the issue occurs and if it can occur from the start of a gameplay session or over time.

This number can be found at the bottom of the cartographer

Were any of your settings changed from the default options and have you added any custom Islands?

What steps, if known, can cause this issue to occur for you?

-Have you tried reloading your save, game or PC?
-Have tried reinstalling the game?
-Is there anything else you tried to alleviate the issue? Please let us know whether it was successful or not.
-Please feel free to provide any other information you feel may be relevant to this issue.
-Images / Links - If you have any images or clips of the issue happening, please include them.

Thank you for this, detritus.

We tried it with original game seed. We tried your whole list of extras. It is a strange issue.

Have you tried on the latest update that released today?

Going to some time this week.