CPU Multicore issue - Unity-related - CPU Affinity!

There is an issue with Unity and games that haven’t been optimised for CPUs with many cores. Games like Subnautica and Among Trees have this same issue (and is fixed the same way). If you have a high-end CPU with multiple cores and you’re getting poor performance, you have to change the CPU affinity for the game to only use 4 cores. You will have to do this every time you run the game, or there are a few permanent options at the bottom.

With Stranded Deep, I was getting sub-30 fps before at medium or low graphics settings, now with setting CPU affinity to 4 cores, I’m getting over 120fps solid on Ultra. See my video how to fix it (from Among Trees - same fix for Stranded Deep):

To set up CPU affinity automatically, you can use Process Lasso or see this: https://technowikis.com/9507/put-priority-and-processor-affinity-in-windows-10-8-program

Team, can you please fix this so that we don’t need the workaround? Thanks!

Here’s the same fix with Stranded Deep:

Hi Burnhill,

Thank you for sharing this information with the PC team but please do not tag devs in reports as requested in the Staff Introductions! post. Team members go through bug reports regularly so there’s no need. Thank you for your understanding.

Oops sorry! I’ve updated the post.

1 Like

Thanks Burnhill :slight_smile: