Can't load in game

Hello i have a problem with loading in game on PS5 when i make a new world it let’s me in the Plane when i make it to the surface it’s load again for the island but I stuck in loading for ever it says (CLEANING UP) can anyone help me ??

Hi Oday, welcome to the forums,

I’m sorry to hear this issue has occured when starting the game.#

Please let me know:

  • Are you starting a Multiplayer or Single Player save?
  • What Seed number is in use for this save slot? (This number is at the bottom on the main menu in the cartographer)
  • Have you tried other save slots or seed numbers?
  • From what you can tell, does everything appear to behave as intended in the opening sequence?
  • Are you playing version 2079? (this number is in the bottom left hand corner of the screen in the main menu)
  • Did you change any settings when setting up and starting the save?

Any extra information you can provide about your experience would be greatly appreciated. Players who have experienced issues similar to this have had success in loading a private solo multiplayer game. If you are playing single and changing things such as the seed number or save slot does not work for you, you may wish to try a multiplayer save.

I think this may be related to the seed number however so please let me know what the current seed number is before you try changing it.


I tried both Multiplayer and Single Player all i get stuck at cleaning up.

2- I don’t have a seed number I’m making a new world I don’t have any save

3- when i go to cartographer i also get stuck at creating.

4- at the opening in the plane everything is good but when i go to the surface it’s load again then i stuck at cleaning up.

5- yes I’m playing at version 2079.

6- no I didn’t change any settings.

I tried everything single player and multiplayer or creating a seed i get stuck at all I deleted the game 4 times and downloaded it again nothing works again i got stuck at the second load after the plane crash it says ( cleaning up ) I hope you help me I really love the game…

Here some footage…

Hi Oday, thank you for that information.

You Cartographer should still display a seed number at the bottom screen for the save you’re about to start as this can be changed before loading into a save if a player wanted to create a custom one. The seed number is the same for both Single Player and Multiplayer in the one save slot. Please confirm for me that when you say the cartographer gets stuck at creating, do you mean creating islands or changing your seed number? You mentioned having difficulty changing your seed number but I want to make sure. Do any numbers display before you get stuck at this point? - If it’s at all possible to get a clip of this happening too that would be much appreciated.

Please try clearing the cache of your console by shutting down and unplugging your system for 2 minutes before rebooting. You may wish to do this after uninstalling the game for a fresh install. I would also recommend removing any temp pre-save data for Stranded Deep that may have been created before reinstalling so the game doesn’t try to pull any data from that - If you have tried this, please let me know.

Thank you also for taking the time to share that footage, I shall add it to my report for the team. I see from the footage that you are loading via Save Slot 2. Did you change save slots and try different ones or have you always tried to load from this slot?

Hi Clare
Here some footage when i go to Cartographer at first i press at Cartographer then it showed me a lot of errors after that it let me create a new seed but I back out i press cancel i didn’t press ok then i got stuck at that like you see in the footage.

In the second footage i I’m showing you that I don’t have any save slots.

this time I press ok to make a new seed as you see i got stuck again at a (New World Is Being Created).

And yes I tried clearing the cache of my console didn’t work, I don’t have any data for stranded deep in my PS5.

And yes before I record i changed save slots to 2, I tried everything save slot.1 and 2 and 3 and 4 nothing works, Since I downloaded the game like 3 days ago i was trying everything nothing work.

I don’t know if this information is useful but i played the game at PS4 and i never had a single problem but when I change for PS5 i had all this problems.

Hi Oday, thank you for those extra clips, I think the error messages you are seeing when trying to load the cartographer are the key here. I’m not a dev so I cannot say for certain what is causing it but I’m going to pass this onto the team.

It is also very interesting that you were able to play on PS4 without issue but playing on PS5. Are you using the same profile from your PS4? Did you try transfering any saves from the PS4 to the PS5.

Thank you for also confirming you tried other save slots and that there is no temp files in the Stranded Deep save folder on your console.

If the team have any other workaround suggestions I’ll post them here but they may need to look into the cause of this further.

Can you confirm for me what region your PS5 is set to and if the PS4 was set to a different one?

Yes I transferred my saves to PS5 but i didn’t get my save slot ( my world ) back then I deleted all my saves,but I don’t care i want to start from the beginning it’s fun, and I’m playing with the same account in PS5.

My region is Middle east.
But I never changed my region on PS4 so I don’t know what my region is on PS4, also I always play on asia or Middle East.

Thanks for that extra info Oday, I’ll let the team know as this may help them in trying to replicate the issue internally.

Clare it’s working right now I solve it :joy::joy::joy:
I just change my PS5 language from Arabic to English, thank you very much.:heart:

1 Like

Ah that’s excellent news! Thank you for letting us know Oday, I’ll inform the team as they may wish to continue looking into this as we haven’t had reports of it before and they said it was definately an error in the map that was happening which may have been caused by an issue with how the game was trying to localising.

I’m mostly glad to hear you can play without issue now with the language change, thought I understand it’s not ideal for the moment.