Can't build properly

Xbox series S
No fix yet
2 similar bugs

Bug#1 I cant build anything on a raft (3x3) nothing works.

Bug#2 Building a house the stairs can’t connect to another foundation level and it wont connect a floor to anything not even a foundation.

I’ve cleared my Raft of all additions and nothing works and I did notice that there is a 1 square space required to build a separate build. Maybe the same requirements are for the raft and I may have to build a 5x5 raft to have a 1 square space between raft add-ons and building specs.

Is there any rocks in the way? For foundations

For the raft, it could be going through the sand or the character

Have the raft in water and then place it and foundation in the water

Hi TheReaper5469, welcome to the forums,

Thank you for reporting each of these, I have responded to them in turn below.

  1. Can’t build anything on a raft:
    Can you confirm for me if you have raft floors placed ontop of your raft base parts? If so, please let me know what you’re trying to attach and what you can see in game (item ghosts remain red, item ghosts appear white but will not build, etc)
    You should be able to place items on sections next to each other so long as there is space.

  2. Stairs not connecting:
    Were the two sections you are trying to connect built seperately? While you can place items anywhere, once a foundation piece is placed, it sets the level for items attached to it. If you placed another foundation piece seperately and are trying to connect it, then the build system will likely not line up as you cannot have multiple foundation levels within the same build.

If the situations above do not sound they match what’s occuring in your game, please provide more information and I will do my best to assist.

  1. I’ve placed them ontop of the raft floor and it shows red no matter where I put it.

  2. I’m trying to contact A)the foundation from the stairs, B) foundation with stairs to a 2nd level, and C) any floor to the foundation or stairs.

Did you use any walls to make the floors go white and not red?

No matter what building part I use the floors wont go white. even when I add a foundation under the stairs it won’t allow it.

Like Clare said, you can’t have two levels of foundations in the same build. Stairs leading from one foundation downwards to another foundation don’t work, the stairs will not allow anything to snap to it.

it was stated if a 2nd foundation was placed you cant connect them. these issues are 2nd player issues not main. eother way its broken for coop. among other things

Hi TheReaper5469,

My apologies for the delay in responding to your post.

  • Can you confirm for me what add-ons you are trying to place on the raft? And if you are building on water or land? If building on land, please try dragging the raft out to the water and seeing if you can attach items there.

  • To clarify regarding foundations: Once you place a foundation in an area, it sets the “Foundation Level” for that building and a small area surrounding it. If you have a second level on a building but the with foundations you’re trying to connect to are from a different building, you will not be able to connect them.

It may be benificial to see a video or image of the issue you’re experiencing, so myself and the team can better understand your set up and see where the error may be occuring

However you mentioned in your last comment that these are “2nd Player Issues” are you Player 2 on a multiplayer save?

If so, can your host build without issue?

Are you trying to connect items they’ve built or build on a raft base they have created?

Please let me know:

  • Are you in the same household on the same connection?
  • Are you both using wireles, wired or 4/5G connections, etc?
  • When checking the Network Connection details in your console, what is the NAT type for yourself and the host?
  • What region are you using (have you tried using other regions?
  • What brand of Router are you and your host using?
  • Have you tried swapping who is hosting? If so, did that help at all?

Any additional information you can provide about your gameplay setup would be greatly appreciated and may help me to offer further workaround suggestions.