0.80.01 Update Unplayable

[MacbookPro][0.80.01][FPS] Unplayable Lag

Every time I try to play the game, it has an Frame Rate that is so low that the game is unplayable now. Before the 0.80.01 “Major Update”, the game ran perfectly. I have lowered all settings to the lowest they can go and set them for laptop quality. I lowered the resolution of the game and made it play in window. This slightly sped of the FPS but still not enough. If I try opening the game from a desktop icon, it says the game is damaged or incomplete and can’t open at all. I would like to be able to play the game I paid for because I love this game.

All settings were set to lowest, off and laptop quality. I tried adding custom maps but unadded them because I thought maybe they were slowing the game down but it turned out it ran too slow with or without the maps.

Downloading the 0.80.01 update you guys just sent out caused the problem.

I tried uninstalling the game and then reinstalling several times. I tried playing the game through the Nvidia Geforce Application. I tried playing on the lowest possible settings.
My Macbook Pro is completely up to date with OS Big Sur and has well over the minimum system requirements to play.

PLEASE HELP! :frowning:

1 Like