PS5 [2116] Call me Ahab still bugged after update

Summary
Call me Ahab is still locked on my save. This save file was created before the initial Ahab fixes started coming out. Unfortunately by this point I had already lost the shark trophy (I think I remember that I tossed it in the ocean in frustration lol). I still have the Eel and Squid and all item portraits have the brown background to indicate they have been crafted.

Seed
#14853428

Settings
Were any of your settings changed from the default options and have you added any custom Islands?

Custom island, created once, long after killing the sea monsters.

Steps
What steps, if known, can cause this issue to occur for you?

I killed the sea monsters back in December ‘22, I initially crafted the trophies (with the quick menu for some I believe, definitely the first one at least) immediately after the boss fight and this seems to have caused the initial problem.

Extras
-Have you tried reloading your save, game or console?

Yes

-Have you tried clearing the cache of the console by shutting down for 2 mins before rebooting?

Yes

-Is there anything else you tried to alleviate the issue? Please let us know whether it was successful or not.

Mounting/unmounting the trophies I do have, keeping them with me and leaving them alone, loading the game with them equipped and with them on the floor

I’m wondering if you have any further suggestions or whether I should just capitulate and replay the whole game after all this time.

Many thanks

Hi Munchy, welcome to the forums,

I’m sorry to hear Call Me Ahab has still not unlocked for you. Following further reports since the update, and checking a player provided save file, the team believe that if a trophy was created on a custom island in an earlier version, it may be the cause the the achievement remaining locked. They’re looking to rectify this in the next update which should hopefully unlock the achievement for those who are still having issues.

To be sure that this is the cause, and not another underlying problem, do you recall if you crafted any of the trophies on a custom island?

So long as the trophies are registered as crafted, it shouldn’t make a difference if you’re missing one, but I’ve asked the team to confirm this for me and will let you know when I hear back from them.

Hi there,

Obviously this happened back a number of months ago so I’m only going from memory, but I’m sure I didn’t generate a custom island prior to reaching the final objectives.

I recall that I generated an island to help me find fuel materials for the end of the game, I wouldn’t have done this prior to reaching that point and I know I needed to defeat the sea monsters to reach that stage.

I’m pretty certain that I’m right in this. The first one was quick-crafted on a raft immediately after killing the creature and I think the rest were crafted through the proper menu.

I recall seeing one of the trophy items grayed out despite me having the item crafted however the trophy that was gray changed each time I would load in.

I obviously do not know how the trophy flags work and I won’t claim to have any technical knowledge of game development, but I wonder if something as simple as allowing players to craft a sea monster trophy multiple times (as you can with the corresponding aircraft components you unlock) would be enough to trigger the trophy check?

Thanks for your communication on this, I know it would be as simple as just restarting a new save but honestly I’m kind of curious to see it through now haha.

Hi li logged in And crafted an item And the trophy “gotta craft them ALL” popped finally i got the Platinum

1 Like

Hi Munchy,

Thank you for confirming that info to the best of your memory. I’ll let the team know.

What might be beneficial to them, is to see a copy of your save file to see if they can determine why the trophy is not unlocking and if one of the trophies is registering as uncrafted.

When investigating this issue, the team came to the conclusion that the issue with the menu showing the incorrect background was purely visual, and should not have had an impact on the “Call Me Ahab” trophy, it is just unfortunate that they overlapped and it looked like it was a source of the problem.

While I’m not a dev myself, I believe the check is a true/false check to a trophy being crafted, which is why you should not need the physical trophy thrown into the ocean. Regardless, I will pass on the feedback regarding the option to recraft the trophies to the team.

If you’re happy to share a copy of your save file with us, please follow the steps below. As it’s a PS4 game on a PS5, the transfer should be fairly similar.

  1. Turn on PS4 / PS5

  2. Insert an External USB Drive into one of the 2 USB ports on the front of the console.

  3. In the main menu, go to “Settings”

  4. Click on “Application Saved Data Management”

  5. Select “Saved Data in System Storage”

  6. Select “Copy to USB Storage Device”

  7. Select Stranded Deep

  8. Select all files and press “Copy”

  9. Wait until transfer is complete

  10. Remove External Drive

  11. Zip up all files copied to USB drive including “.bin” and “Profile” files

  12. Upload the zip file to Google Drive, One Drive, Dropbox or similar and send me a direct message with the download link. I will then pass the save file onto the correct team members.

Thank you

Hi Clare,

Thanks for your detailed feedback. I’d love to pass my save file along but currently I don’t have a USB nor do I have access to a PC frustratingly enough.

If this changes I’ll get back in touch!

1 Like

No worries - thanks for letting me know Munchy!