[ps4][Co op][The Meg not rewarding craft ables]

My partner and I killed the Meg and it popped up on our screen after, saying we unlocked a trophy and an aircraft part. When we went to look under story section and vehicle section the craft able rewards are not there. It’s still blank. The Meg is also gone so we cannot try again.

I don’t know what that is.

Were any of your settings changed from the default options and have you added any custom Islands?
No settings changed and no custom islands added.

What steps, if known, can cause this issue to occur for you?
Not currently known.

-Have you tried reloading your save, game or console?

-Have you tried clearing the cache of the console by shutting down for 2 mins before rebooting?

-Is there anything else you tried to alleviate the issue? Please let us know whether it was successful or not.
Tried sleeping, saving, and exciting the game. Still no rewards.

1 Like

Hi Free2bme0615, welcome to the forums,

I’m sorry to hear this issue has affected your multiplayer save. This is an issue that the team is aware of and are investigating.

Please try opening the quick craft to see if the option to craft the story items appears there for you or your partner, even though there are no additional items in your inventory. Some players have found success using the quick craft menu as a workaround for this issue and please let me know if this does/doesn’t work for you.

I have a Known Issues post on this issue here: [Known Issue][PS4/XB1] Crafting Menu Reset / Items Locked - If I receive any updates from the team on this issue or hear of any other potential workarounds they’ll be posted in that topic

This same bug happened to a player that was on my live stream of me playing stranded deep about two days ago. Can confirm the workaround for this is as Clare suggest use quick craft via holding r1 while in the water after meg dies and you should be able to craft the trophy in the water.

Hi TheBacon-420,

Welcome to the forums and thank you for letting me know that workaround worked for you. I shall let the team know this is possible under the conditions you mentioned above as it may help them in their investigation into the nature of the issue.

[Edit: I’ve added doing this within the boss area after killing it in the workarounds session of the Known Issues link above]

Free2beme0615, as per TheBacon-420’s comment above, if you are unable to craft the trophy using the quick craft menu on the island, it may be worth returning to the boss area and trying to quick craft there too.