PlatformPS4/PS5 Two saves on two different host unable to finish the game

For the topic title above, please use the format:
[Platform][Game Version][Affected Topic] Post Title
For example: “[XB1/PS4][1820][Audio] Sharks singing too loud at night”
The game version number can be found at the bottom left of the main menu.

For the main post please follow the summary as best you can:
Feel free to edit and replace each section with your own info.

Please provide as much detail of the issue and your experience with it as possible. Please also let us know how frequently the issue occurs and if it can occur from the start of a gameplay session or over time.
We killed the Meg two times no unlock of crafting or trophy anything that indicated we did it we then killed the other two bosses with no luck of it magically catching up and unlocking the trophies and crafting so we can end the game. We tried multiple times visiting the huge ship putting some food and water there. We tried another save with a different host we beat the Meg again and again nothing no unlock. On the first save it always shown me as day 0 but on my friends save the second time we tried with a new host he did have updated days survived. Yet still no unlock of story even tho we got all the pop ups that we defeated and said that we would unlock crafting. We spend so many hours and wanted to finish the game for us to have this problem ruin the game for us
This number can be found at the bottom of the cartographer

Were any of your settings changed from the default options and have you added any custom Islands?
What steps, if known, can cause this issue to occur for you?

-Have you tried reloading your save, game or console?
-Have you tried clearing the cache of the console by shutting down for 2 mins before rebooting?
-Is there anything else you tried to alleviate the issue? Please let us know whether it was successful or not. Not successful
-Please feel free to provide any other information you feel may be relevant to this issue.
-Images / Links - If you have any images or clips of the issue happening, please include them.

Hi KatJacksonn, welcome to the forums,

I’m sorry to hear you’re experiencing this issue in Stranded Deep. Thank you for reporting it to us.

The team are aware of an issue that is causing story items to remain locked after the bosses are killed. I have a known issues report on this here - [Known Issue][PS4/XB1] Crafting Menu Reset / Items Locked - Some players have found that they can craft the story items if they use the quick craft menu rather than the main crafting menu. This may need to be done in the boss area if it is not possible after returning to your island.

For the days survived, in the main menu it will list days survived for the single player save in the same slot. To see the Multiplayer days survived, you will need to access the pause menu within the multiplayer save. If this menu or your watch still said 0 days survived while you were the host, please leet me know.

I understand this issue is frustrating and I hope the workaround suggested above may help you in progressing in the game while the team work to resolve this issue. Thank you again for reporting this and sharing the details of your experience, I will add this to my report for the team.