PC-STEAM 0.90.04 Multiplayer, Game Crash Clicking Play Online

Brand new install of the game, got it on sale, when i click to play Online, host game, it begins to create “new game” screen flashes black then crashes. Tried joining a game and the screen flashes black then crashes. I can play single player with no issues. Tried the game mode in DirectX 11 and OpenGL. Tried Exclusive and Borderless Window as well. Uninstalled, reinstalled, tried different graphic settings i.e., medium, low, laptop, resolution settings low, windowed mode. I eventually got an error when trying to launch the game after multiple attempts:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ComponentModel.Win32Exception: The system cannot find the file specified
at System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo startInfo)
at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
at Launcher.Launcher.LaunchGame()
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
Assembly Version:
Win32 Version: 2.0.50727.9151 (WinRelRS6.050727-9100)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll

Assembly Version:
Win32 Version:
CodeBase: file:///E:/Steam/steamapps/common/Stranded%20Deep/Stranded_Deep_x64.exe

Assembly Version:
Win32 Version: 2.0.50727.9149 (WinRelRS6.050727-9100)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/

Assembly Version:
Win32 Version: 2.0.50727.9149 (WinRelRS6.050727-9100)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/

Assembly Version:
Win32 Version: 2.0.50727.9149 (WinRelRS6.050727-9100)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/

Assembly Version:
Win32 Version: 2.0.50727.9149 (WinRelRS6.050727-9100)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging

For example:

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Is this trying to launch the game for 32bit? Mine is 64, but why does single player work but not mulitplayer? I have no driver updates for windows or my GPU, steam is updated, i am at a loss. I even installed to a different slot, from HDD to SSD. After recieving the above error report i verified the game files and 1 did fail and needed to be redownloaded. I even went so far as to load up the “beta” build of 0.90.00 to see if that worked but did not.

The game crashed once again and when verifying the integrity of the files it just hangs at downloading, i can click update, but it pauses then says to try again. In the download section it says disk write error, see picture below. I have updated other games including: Hunt Showdown, Payday, Among Us, and others with no issues today hoping that maybe my steam was messed up, but seems that it is just this one.

1 Like

I’m having the exact same problem. My friend hosts the game. I click “Join Session” The entire game bricks out. The game crashes with the unhandled exception, launcher will not open the game. Disk write error on the game. Wont update. I have to uninstall the game and reinstall it in a whole new disk location…

Is this a known bug? Is there any information on it… I hope.
Haven’t seen anything on Google or Steam about it either…

I also am having this same issue, but when it crashes, i tried validating my files for the game. Everytime it says that a file was missing and re-downloads that file. But still everytime i try to host or join an online game it does the same thing. Hope we can find something out on this soon as i have gotten some friends interested in the game and would enjoy playing online with them.

1 Like

Ok, So I believe I figured out my issue, dont know if it will work for you too. But I was able to get online and host a game, first validate your game files to make sure they are all there. Then browse the local files, in there you will find a application file for “Stranded Deep x64”. When i ran the game from this i was able to get online play working. Hope this helps.