[PC][0.90.00]Online Co-op crawling with bugs

I expect bugs when there’s this kind of update, especially when adding multi-player to a game. All the bugs we experienced were syncing style errors, according to my sis who is a programmer. So here goes, all the bugs my sis and I found when playing online co-op for the first time today (as a note, we both are running Windows 10 and have no mods on the game):

~Have to rename the game every time we play. Wasn’t sure if we were going to have to start over or not, turns out not, but it was rather confusing.

~Host avatar suddenly disappearing and the other person seeing the objects she is moving floating by themselves. She saw me swim up onto the beach, and from there she says it looks like i dropped into the ground and she didn’t see me again for the rest of the session. Relog fixed.

~A stack of four sticks in host’s inventory that were there but not there. I couldn’t put them in my hands or use them in any way, yet they ate up an inventory slot. Relog fixed

~When host is saving, get a message about “null inventory. this should not happen. contact the Beam Team.” That’s only happened on the second save but not again. It happened while i had the sticks I couldn’t get rid of.

~Guest unable to see things host drops about 50% of the time.

~Guest unable to pick up items that were stacked on each other. Only part of the time.

~Guest seeing “ghost” images of things that the mouse highlighted. (for example, she looked at the water still to take a drink, but when she moved away, she still saw the highlighted water still in front of her looking very much like the white ghost image of an item when you are finding the right place to build it.) sometimes it resolved itself by her crafting something, other times she had to relog to fix.

~Guest and host get messages about whatever fish we speared floating away, even though it is either on the end of the spear or already in the inventory. It doesn’t seem to matter who speared the fish, we both get the message. As a side note, i get this in solo too whenever i spear a fish since the update.

~Guest has disappearing items in her inventory. She picks them up and ■■■■ they are gone. Not dropped, just gone. This only happened three times during the hour long session. they never come back.

~Guest can’t see when cooking food has finished cooking. It says that it’s cooked the moment the meat is put onto the fire, but when picked up, it’s still uncooked. this might be because i had already cooked and eaten one medium crab and put the second one on for her. We think she was still seeing the cooked crab that I already took off and not the new one.

~Host suddenly unable to build anything at all after the first two items were built. Then suddenly again later able to build again. No noticeable reason for it.

~Guest unable to save at shelter. She got the message that she couldn’t save while the host was “knocked out” though I was standing right beside her.

~ Host tools missing on log in. they were never seen again. I’m now dropping my tools in a pile on the ground before i save and picking them up when i log back in just in case.

~Animals are set to passive, but guest is still being poisoned by everything, even though host is not. Antidote works but also a relog got her unpoisoned the second time.

~guest unable to use tools to gather things until after a relog again.

~guest unable to take an item out of her hands (she ran around holding a rock until relog again)

That’s everything we noticed, that I can remember off the top of my head, from our first hour long online co-op session. The last four are from, the second session. I’m hoping this doesn’t put her off the game. It’s her first time playing it lol. But as we say, bugs can’t be fixed if they’re never reported, so there you go !

there are a couple of bugs that happens in both solo and online co-op that didn’t happen before the update:
~when your inventory is full, it buzzes at you when your mouse even passes over something that can be picked up. When you are moving items from one end of your island to another and pass a few mounds of your things, the buzzing sounds going off rapidly over and over can be overwhelming. The people in my house have complained about the noise lol. i’m not sure how to even turn that down without turning the game down. also not sure this is a bug but something you have decided the game needed. Up until the update, it only buzzed like that if i actually tried to pick something up with a full inventory. Now it doesn’t care if I’m trying to pick it up or not, it just keeps buzzing D:
~Also we can’t build storage shelves on rafts anymore. When we try, they float in the air above the raft. They go down just fine are structures on land, but not on any raft made of any material or any location on the raft. they just float there above us.

Not sure if this is the seed number or not since it is NOT at the bottom of Cartographer but at the top of it (there is no number at the bottom): 11878953

No custom islands. changed drop from q to b, but i did that right at the start of my solo game and none of these bugs are in solo, only in co-op

Not sure about steps. They just sort of happen. We think it might be the same kind of syncing error that a lot of people are getting.

Reloading the game worked for some of these bugs, but not all of them. I mentioned which ones reloading helped with the bug itself.

-Images / Links -
It won’t let me upload the images because i’m a new user…


Hi Aria_Rain, thanks for such a detailed report.
We are looking into all of the issues you’ve mentioned.

1 Like

We experienced all but two of these same issues. I am on Mac, husband is on Linux via Steam. Additional issues:

I was getting HIS notifications as well as my own on my watch. “Honey, you’re hungry, eat something.” Just like real life!

On Linux, he cannot see when it’s night time except near a fire. Like, no moon helping him. No flashlight helping him. And if I am holding a light source, he can only see a very narrow sliver of light from it. Like, I was turning on a flashlight, and he saw in the distance a circle where it was kinda hitting a tree away from us. No light around us at all, as if we were still in pitch darkness. He and I have no such issue when HE is holding the flashlight.